Closed Bug 1841506 Opened 1 year ago Closed 1 year ago

Importing window remains in infinite loading if triggered after a profile refresh or after using the --migration command

Categories

(Firefox :: Migration, defect)

Firefox 116
Desktop
All
defect

Tracking

()

VERIFIED FIXED
117 Branch
Tracking Status
firefox-esr102 --- unaffected
firefox-esr115 --- unaffected
firefox115 --- unaffected
firefox116 --- verified
firefox117 --- verified

People

(Reporter: atrif, Assigned: mconley)

References

(Blocks 2 open bugs, Regression)

Details

(Keywords: regression)

Attachments

(2 files)

Attached image firefox_migration.gif

Found in

  • 116.0a1 (2023-07-02)

Affected versions

  • 116.0a1 (2023-07-02)

Tested platforms

  • Affected platforms: Windows 10x64, macOS 12, Ubuntu 22.04
  • Unaffected platforms: none

Steps to reproduce

  1. Open Firefox with the --migration command or perform a profile refresh from about:support page.
  2. Import data from another browser.

Expected result

  • Importing data works as expected.

Actual result

  • Importing data is not working and the window remains in infinite loading.

Regression range

  • I did a manual regression range: it seems that this started with Firefox 2023-06-10. Most likely with bug 1823537. Feel free to change if you feel otherwise.

Additional notes

  • Attached a screen recording.
  • Error: Cannot initialize Places more than once - BrowserGlue.sys.mjs:3222:13 error is displayed in the browser console.
  • Restarting Firefox fixes the issue.

:darktrojan, since you are the author of the regressor, bug 1823637, could you take a look?

For more information, please visit BugBot documentation.

Flags: needinfo?(geoff)

I really don't think that's right, since that bug is not a Firefox bug.

Flags: needinfo?(geoff)
No longer regressed by: 1823637

My apologies... I somehow mistyped the issue. I meant bug 1823537.

Has STR: --- → yes
Regressed by: 1823537
Flags: needinfo?(mconley)

This is needed in order to clear the gProfileStartup state after a startup
migration from a profile reset.

Assignee: nobody → mconley
Status: NEW → ASSIGNED
Flags: needinfo?(mconley)
Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a8c47414f934
Make sure to run MigrationUtils.finishMigration when tearing down the migration wizard. r=kpatenio
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 117 Branch

The patch landed in nightly and beta is affected.
:mconley, is this bug important enough to require an uplift?

  • If yes, please nominate the patch for beta approval.
  • If no, please set status-firefox116 to wontfix.

For more information, please visit BugBot documentation.

Flags: needinfo?(mconley)

Verified fixed with Firefox 117.0a1 (2023-07-11) on Windows 11x64, macOS 12, and Ubuntu 22.04. The importing window and profile refresh window works as expected when used after opening Firefox with --migration command.

Comment on attachment 9342248 [details]
Bug 1841506 - Make sure to run MigrationUtils.finishMigration when tearing down the migration wizard. r?kpatenio!

Beta/Release Uplift Approval Request

  • User impact if declined: Users that attempt to perform a migration after a profile reset or a startup migration will find that the migration wizard never finishes loading.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Very small patch that just ensures that teardown happens properly when the migration wizard goes away.
  • String changes made/needed: None.
  • Is Android affected?: No
Flags: needinfo?(mconley)
Attachment #9342248 - Flags: approval-mozilla-beta?

Comment on attachment 9342248 [details]
Bug 1841506 - Make sure to run MigrationUtils.finishMigration when tearing down the migration wizard. r?kpatenio!

Approved for 116.0b4

Attachment #9342248 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Pushed by dsmith@mozilla.com:
https://hg.mozilla.org/releases/mozilla-beta/rev/720b78fba255
Make sure to run MigrationUtils.finishMigration when tearing down the migration wizard. r=kpatenio,a=dsmith
Flags: qe-verify+
QA Whiteboard: [qa-triaged]

Verified fixed with Firefox 116.0b4 on Windows 10x64, macOS 12 and Ubuntu 22.04. The importing window and profile refresh window works as expected when used after opening Firefox with --migration command.

Status: RESOLVED → VERIFIED
QA Whiteboard: [qa-triaged]
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: