If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Alt text for directly loaded images is absurd

VERIFIED DUPLICATE of bug 177747

Status

()

Core
ImageLib
--
trivial
VERIFIED DUPLICATE of bug 177747
15 years ago
13 years ago

People

(Reporter: Kevin Stange, Assigned: Stuart Parmenter)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021207 Phoenix/0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021207 Phoenix/0.5

If you load an image directly, say
http://www.simpage.net/misc/39827468192837.jpg and right click the image to view
its properties, Mozilla will identify the Alternate text as:

"The image “http://www.simpage.net/misc/39827468192837.jpg” cannot be displayed,
because it contains errors."

While this is all well and good for producing output when the image fails to
load, the fact that it is hacked in as alt text and appears in the properties is
rather absurd.  The other side-effect is that dragging the image off of mozilla
to create a shortcut results in a file named:

"The image “http---www.simpage.net-misc-39827468192837.jpg” cannot be displayed,
because it contains errors..url"

This is also rather absurd.

Reproducible: Always

Steps to Reproduce:
1. Load an image directly in the browser
2. Right click the image and hit properties
3. Read alternate text field
4. Dismiss properties
5. Click and drag the image to your desktop
6. Read the filename of the shortcut that is created

Actual Results:  
Insanity

Expected Results:  
Less Insanity

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 177747 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.