Extensions of downloaded files are not correct

VERIFIED DUPLICATE of bug 65827

Status

()

Toolkit
Downloads API
VERIFIED DUPLICATE of bug 65827
16 years ago
10 years ago

People

(Reporter: Jos Pletzers, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021207 Phoenix/0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021207 Phoenix/0.5

When downloading a "*.doc" file or any other format accept a "*.zip" file the
download manager asks what to do whith it. When you hit save the file is not
saved correctly but with a other extention. 

For example i download the file Josh.doc and hit save when opening the file from
windows the file is stored Josh.doc.asp so windows does not recognises the file
extention and does not open word to show the file.

Reproducible: Always

Steps to Reproduce:
1.Click on a "*.doc" file to download.
2.save it to harddisk
3.open it in windows

Actual Results:  
The file is not stored as *.doc but as *.doc.asp

Expected Results:  
save the file with correct extention in this case *.doc instead of *.doc.asp

Comment 1

16 years ago
Can you give a URL where this happens?  The extension a file is saved with
depends largely on the content-type header sent by the server, so it might not
be possible to reproduce your problem without trying to download a .doc from the
same server you tried to download it from.
(Reporter)

Comment 2

16 years ago
Yes i can give you the URL but it is in a webbased e-mail system it is a 
secured outlook 2000 webaccess page. So i don't think that URL is helpfull. 
And i don't post my username and passwrd over here hou you can all understand 
that.
(Reporter)

Comment 3

16 years ago
Sorry guys for the inconvenience.
I messed a few things up 

changed bug status to fixed
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

16 years ago
Damn i must be drunk or somthing.
Reopend the bug

After some testing i discoverd phoenix always wants to open/save every file with
Macromedia dreamwaever. Most files are saved as .asp but when i click in the
download window on save as type (all types) there is no problem.
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Comment 5

16 years ago
Try creating a new profile and testing it again.

Comment 6

16 years ago
*** Bug 191591 has been marked as a duplicate of this bug. ***

Comment 7

16 years ago
This is very likely a server configuration issue. 

Comment 8

16 years ago
Reporter: do you recall if Phoenix crashed during the download of a file with a
.asp extension? I've got some reason to believe that that might be the bug. See
this MozillaZine discussion for more info:
http://www.mozillazine.org/forums/viewtopic.php?t=5504

If this is what occurred then trying a new profile would fix the problem (it's
still a bug, but it means that there's a work around).

Comment 9

16 years ago
I've seen this problem in Mozilla too. Sometimes, it adds the wrong extension.
This can happen on image files as well.

Dupe of a Mozilla bug?

Comment 10

15 years ago

*** This bug has been marked as a duplicate of 65827 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago15 years ago
Resolution: --- → DUPLICATE

Comment 11

15 years ago
v.
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.