Closed Bug 1843386 Opened 11 months ago Closed 10 months ago

Rich suggestion dissapears when complete

Categories

(Firefox :: Address Bar, defect, P3)

defect

Tracking

()

VERIFIED FIXED
117 Branch
Tracking Status
firefox117 --- fixed
firefox121 --- verified

People

(Reporter: daleharvey, Assigned: daleharvey)

References

Details

(Whiteboard: [sng-scrubbed][blocked-ux])

Attachments

(1 file)

If you are typing in a name, "obama" for example, you will see a photo of obama up until you type the last letter "a", at that point while the API still returns a rich suggestion for obama, it gets deduplicated with the heuristic result as they have the same URL (https://www.google.com/search?client=firefox-b-d&q=omaba)

This is a tricky situation, we expect the hueristic result to come first and have a stricter timeout for it, the suggestions can often timeout and are always the slowest results to return but it is also quite confusing to have the result dissapear

Severity: -- → S3
Priority: -- → P3
Whiteboard: [sng-scrubbed][blocked-ux]

For now we should just avoid deduping rich with non rich. That's what all the other browsers are doing anyway so users should not find it strange.
In the future if the rich suggestion appears just after the heuristic, it would make sense to dedupe but "upgrade" the heuristic with the additional rich information (pretty much merge the 2 results).

Assignee: nobody → dharvey
Pushed by dharvey@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e92949e4c114
Dont deduplicate rich suggestions. r=mak
Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → 117 Branch

I've managed to reproduce the issue using Fx 117.0a1.
The issue is verified fixed using the latest Fx121.0a1 on Windows 10 and Ubuntu 20.04. Rich Suggestion no longer gets updated when typing the last letter of the word.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: