DHTML layout problems using absolute positioning

RESOLVED DUPLICATE of bug 184349

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 184349
16 years ago
16 years ago

People

(Reporter: Todd Buiten, Unassigned)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.0.3705)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2.1) Gecko/20021130 and Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/2001130

I have a multi-level menuing system written in Javascript and DHTML.  If you 
hit http://www.buiten.com using Gecko/20020826 (1.1) or IE 6.0 then you'll 
notice that the submenu that appears when you hover over a menu item is top-
aligned with the submenu item.  In Gecko/20021130, the top of the submenu 
starts about 10 pixels or so above the top of the menu item.  I tested on both 
Linux (2.4.18 kernel running KDE on XFree86 3.3.6) and Windows XP.

Reproducible: Always

Steps to Reproduce:
1. Go to http://www.buiten.com
2. Hover over the word "Generator" in the left nav pane and wait for the 
submenu to pop up
3. Notice that the top of the "Generator.com" div is not line up with the top 
of the "Generator" div

Actual Results:  
The submenu was not top-aligned with its parent menu item.  It happens at all 
levels of submenu.

Expected Results:  
Mozilla should have worked just like it did in Gecko/20020826, which was 
consistent with IE as well.

I'm using a default install with the modern theme.

Although I left the severity at normal, I think it's really somewhere between 
normal and critical.  Will I die if this doesn't get fixed?  Well not really.  
But if we really want people to use DHTML and it keeps breaking like this then 
it just makes major headaches for those who have to write special code for each 
major version of the browser.

*** This bug has been marked as a duplicate of 184349 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.