onkeypress and onkeydown is not working correct...

RESOLVED INVALID

Status

()

Core
Event Handling
--
major
RESOLVED INVALID
15 years ago
12 years ago

People

(Reporter: michael bystrom, Assigned: saari (gone))

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 obsolete attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:1.2.1) Gecko/20021130

I just upgraded to MacOS 9.2.2 from 8.7 on my PowerBook G3 and Mozillas Event
Handle collapsed.

onkeydown's [e.type] will return "onkeypress" and it's [e.which] do not return
some of the charNum correct. Like the arrows, they now return 0 but correct if
you use onkeyup

This was NOT a problem with OS 8.7!

Similar OLD bugs:
http://bugzilla.mozilla.org/show_bug.cgi?id=126436
http://bugzilla.mozilla.org/show_bug.cgi?id=162948

This is a stupid bug and should be fix fast. It's needed for games and DHTML stuff.

Reproducible: Always

Steps to Reproduce:
Just type anything on your keyboard
(Reporter)

Comment 1

15 years ago
Created attachment 108868 [details]
This will show the event bug
I don't know about e.which, but e.type is a bug in the testcase -- it's using
fun1 for the keypress instead of fun2, thus overwriting the results of keydown.
OS: Mac System 9.x → All
Hardware: Macintosh → All

Comment 3

14 years ago
You can see the effects on www.bes.pt. Under BESnet enter 1234567 next to "no
adesão". Moz1.4 on Linux doesn't do anything. Moz1.4 on w32 submits the form.
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/

Comment 5

12 years ago
Comment on attachment 108868 [details]
This will show the event bug

bad test case; obsoleting
Attachment #108868 - Attachment is obsolete: true

Comment 6

12 years ago
I am unable to reproduce this problem without a testcase.  Resolving as invalid.
 Please reopen or add a comment asking for the bug to be reopened if you are
able to reproduce this bug in a new version of Firefox or Mozilla Suite.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.