[IMG] max-height problem on image with display block and height auto

RESOLVED FIXED in mozilla0.9.7

Status

()

Core
Layout
P2
normal
RESOLVED FIXED
18 years ago
14 years ago

People

(Reporter: dbaron, Assigned: dbaron)

Tracking

({css2, testcase})

Trunk
mozilla0.9.7
css2, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Hixie-P2][Hixie-1.0], URL)

Attachments

(4 attachments)

(Assignee)

Description

18 years ago
DESCRIPTION:  The image with class eleven in the above page is displayed with a
height of 600px, when it should be its natural size.

The problem is that when an image with display: block is between its max-height
and min-height, so neither property should do anything, it's getting its
max-height as its height.

STEPS TO REPRODUCE:
 * load attached testcase

ACTUAL RESULTS:
 * the image is 800px tall

EXPECTED RESULTS:
 * the image should be about 300px tall

DOES NOT WORK CORRECTLY ON:
 * Linux, apprunner, 1999-11-09-08-M11
(Assignee)

Comment 1

18 years ago
Created attachment 2756 [details]
testcase described in bug

Updated

18 years ago
Assignee: troy → kipp

Comment 2

18 years ago
Updating to default Layout Assignee...kipp no longer with us :-(

Comment 3

18 years ago
Why are you re-reassing layout bugs? Do NOT touch layout bugs.

The bugs are assigned to Kipp so they can stay neatly organized until we have a
new owner for the block/inline code.

Comment 4

18 years ago
mass moving all Kipp's pre-beta bugs to M15.  Nisheeth and I will
prioritize these and selectively move high-priority bugs into M13 and M14.

Updated

18 years ago
Summary: max-height problem on image with display block → [IMG] max-height problem on image with display block

Comment 5

18 years ago
mine! mine mine mine!  all mine!  whoo-hoo!
Assignee: kipp → buster

Comment 6

18 years ago
moving all buster m15 bugs to m16.
Target Milestone: M15 → M16

Comment 7

18 years ago
important to fix, but no owner currently
Target Milestone: M16 → M20

Comment 8

18 years ago
redistributing bugs across future milestones, sorry for the spam
Target Milestone: M20 → M22

Comment 9

18 years ago
This bug has been marked "future" because the original netscape engineer working 
on this is over-burdened. If you feel this is an error, that you or another 
known resource will be working on this bug,or if it blocks your work in some way 
-- please attach your concern to the bug for reconsideration. 
Status: NEW → ASSIGNED
Target Milestone: M22 → Future
Created attachment 11835 [details]
Testcase which gets around bug in our strict DTD handling
It appears that this now works. However, we should test it again once the
height:% bug is fixed. Also, I tested it on Win2K, David originally reported
the bug on Linux.
Keywords: correctness, css1, testcase
Whiteboard: WORKSFORME?
(actually, just for the record, the testcase I attached did not get around a bug
in our strict DTD, it fixed a bug in the original testcase.)
(Assignee)

Comment 13

18 years ago
Percentage widths on images are completely broken right now.  Don't mark this
WORKSFORME until that is fixed...

Updated

18 years ago
QA Contact: petersen → chrisd
Netscape's standard compliance QA team reorganised itself once again, so taking 
remaining non-tables style bugs. Sorry about the spam. I tried to get this done 
directly at the database level, but apparently that is "not easy because of the 
shadow db", "plus it screws up the audit trail", so no can do...
QA Contact: chrisd → ian
There is still a bug here. I shall attach a testcase. It seems to only occur when 
the 'height' property is set to 'auto'.
Assignee: buster → attinasi
Status: ASSIGNED → NEW
Keywords: css1 → css2
OS: Linux → All
Hardware: PC → All
Summary: [IMG] max-height problem on image with display block → [IMG] max-height problem on image with display block and height auto
Whiteboard: WORKSFORME? → [Hixie-P2][Hixie-1.0]
Created attachment 50145 [details]
Self explanatory testcase

Comment 17

16 years ago
odd: the testcase that Ian most recently added renders identically in todays 
build and in IE6.

Setting to P:2, Normal, mozilla 1.0
Priority: P3 → P2
Target Milestone: Future → mozilla1.0

Comment 18

16 years ago
Nothing odd about it, that would just imply IE6 is broken too ;-)

Updated

16 years ago
Blocks: 73322

Comment 19

16 years ago
So, will this bug magically fix itself in a couple of months, when it is two
years old  :) That would be cool, heh heh heh.
Status: NEW → ASSIGNED

Comment 20

16 years ago
Does that often happen to your bugs? If so, remind me to assign some to you just
before they turn 2 years old ;-)

Comment 21

16 years ago
Could we get a fix for this before the end of mozilla098?  It blocks
implementation of a P2 feature on our PRD, part of a theme for MachV.
Keywords: mozilla0.9.8

Updated

16 years ago
Target Milestone: mozilla1.0 → mozilla1.2

Comment 22

16 years ago
Marc, is there any way you can get some time allocated for fixing this? Being
able to use this would suck less than a javascript based solution for automatic
image sizing (see my last comment in bug 73322).
(Assignee)

Comment 23

16 years ago
So pavlov broke min-height and max-height even more than it was broken when Ian
reopened the bug.  But I have a fix...
(Assignee)

Comment 24

16 years ago
Created attachment 60906 [details] [diff] [review]
patch
(Assignee)

Comment 25

16 years ago
Taking
Assignee: attinasi → dbaron
Status: ASSIGNED → NEW
Target Milestone: mozilla1.2 → mozilla0.9.7
(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED

Comment 26

16 years ago
Comment on attachment 60906 [details] [diff] [review]
patch

r=pavlov
Attachment #60906 - Flags: review+

Comment 27

16 years ago
Comment on attachment 60906 [details] [diff] [review]
patch

sr=attinasi
Attachment #60906 - Flags: superreview+

Comment 28

16 years ago
dbaron landed the fix on 12/10/2001 19:21
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 29

16 years ago
Hixie, in attachment 50145 [details] you say that "this should be after the image, not
under it". Is that correct, and if so, is that this bug or another one?
(Assignee)

Comment 30

14 years ago
See also bug 234686 for further refinements.
You need to log in before you can comment on or make changes to this bug.