Closed Bug 184849 Opened 17 years ago Closed 17 years ago

Page relative anchor tags do not work first time

Categories

(SeaMonkey :: General, defect)

x86
Windows 2000
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 60307

People

(Reporter: prashantrane, Assigned: asa)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130

Page relative anchor links do not work first time.
e.g. say there is a link to "file:///D:/appdev.920/a96624/01_oview.htm#3474"
from some other page say "file:///D:/appdev.920/a96624/toc.htm"

Here is the link code.
<a href="file:///D:/appdev.920/a96624/01_oview.htm#3474">Higher
Productivity</a>

here is the target anchor.
<a name="3474"></a><!--TOC=h2-"3474"-->
<h3 class="H2"><font face="Arial, Helvetica, sans-serif" color="#330099">Higher
Productivity</font></h3>

Now if I get a new window and click on the link it does not go to the exact
location of the anchor tag in the next page. If I go back using browser back
button then it does go back to the correct link. Any page relative links after
that seem to work. But for a new window it is a always a problem.

Also,
Where exactly should the anchor tag position be displayed on the page? It is not
predictable. If there is not enough content in the page then page should be
displayed with completely scrolled down, but in any other case the tag position
should be first line being displayed on screen. In Current broser, it sometime
is but sometimes it is at the center of the page.


Reproducible: Always

Steps to Reproduce:
1. Look at the code samples above.
2. Start a new window, may be a fresh browser session.
3. Link on a link that goes to anchored location in another page
4. It will go to the next page but not correct anchored location

Actual Results:  
Browser does not display correct anchored location.

Expected Results:  
Should have displayed the anchored location as the top line or if there isn't
enough content in the page then scroll the page down fully.
Are there images in the file being loaded above that anchor position?
is this a duplicate of bug 80141?

*** This bug has been marked as a duplicate of 60307 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.