Closed Bug 1848737 Opened 10 months ago Closed 10 months ago

Incorrect link when moving to search engines using the keyboard.

Categories

(Firefox :: Address Bar, defect, P2)

defect

Tracking

()

VERIFIED FIXED
119 Branch
Tracking Status
firefox-esr102 --- unaffected
firefox-esr115 --- unaffected
firefox117 + wontfix
firefox118 + fixed
firefox119 + fixed

People

(Reporter: emilio, Assigned: daleharvey)

References

(Regression)

Details

(Keywords: regression)

Attachments

(3 files, 1 obsolete file)

See STR, in particular how the link in the first item in the addressbar results in "Search with Googletreeherder.mozilla.org".

[Tracking Requested - why for this release]: Probably a recent regression in core address bar functionality.

QA Whiteboard: [qa-regression-triage]

The bug is marked as tracked for firefox118 (nightly). We have limited time to fix this, the soft freeze is in 8 days. However, the bug still isn't assigned.

:cbellini, could you please find an assignee for this tracked bug? If you disagree with the tracking decision, please talk with the release managers.

For more information, please visit BugBot documentation.

Flags: needinfo?(cbellini)

Unfortunately, I was unable to use mozregression to narrow this down. It doesn't repro with mozrgression builds.
It also repros for me in Fx117 beta so it's not new to Fx118 nightly.
Adding tracking for Fx117, though we should revisit tracking once we have the regressor.

Drew, maybe you have some thoughts on this?

Flags: needinfo?(adw)

Last known good build: 2022-06-09
First known bad build: 2022-06-10
Unfortunately, mozregression doesn't take me to a more in-depth range than this:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=b59e3edd8f6ed81cbde389f066d6b7cdee82b086&tochange=46d8ba6116321275d36167c7266eb62eda1b8fd0

Here are the steps used:

  1. Launch Firefox.
  2. Navigate to treeherder.mozilla.org.
  3. Open another tab and close the one with treeherder open.
  4. In the address bar, write tree.
  5. Hold down ALT key (on Windows) and press down key so a shortcut is selected (or just press down key until the shortcuts are reached).

Result: Search with <engine>treeherder.mozilla.org is displayed on the first row, instead of only the term that was written in the address bar.

Has STR: --- → yes

Hey :daleharley! The regression window in comment 5 is quite large and maybe I missed something when looking at it. I wonder if bug 1767186 could explain the current bugged behavior. What do you think?

Flags: needinfo?(dharvey)

This is a reminder regarding comment #2!

The bug is marked as tracked for firefox117 (beta) and tracked for firefox118 (nightly). We have limited time to fix this, the soft freeze is in 2 days. However, the bug still isn't assigned.

From a quick inspection this is looking like a regression from https://bugzilla.mozilla.org/show_bug.cgi?id=1841408, not sure why its not coming up in the range but I reverted it locally and seemed fixed, will get a patch up tonight to fix

Assignee: nobody → dharvey
Flags: needinfo?(dharvey)
Flags: needinfo?(cbellini)
Flags: needinfo?(adw)
Regressed by: 1841408

Took a further look and that bug didnt regress this, I cant actually get my mac to build an old enough working version yet to see where the code to hide the url comes from as there is nothing I can see in the css that would cause this to work as expected.

Will get this fixed and ready for uplift shortly, hopefully within the week however its been broken for over a year without many people noticing.

Set release status flags based on info from the regressing bug 1841408

Severity: -- → S4
Priority: -- → P2
Attachment #9351418 - Attachment description: Bug 1848737 - Hide url in urlbar when action text shown. r=dao → Bug 1848737 - Hide url in urlbar when action text shown. r=adw
Pushed by dharvey@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/759064542ead
Hide url in urlbar when action text shown. r=adw
Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → 119 Branch

The patch landed in nightly and beta is affected.
:daleharvey, is this bug important enough to require an uplift?

  • If yes, please nominate the patch for beta approval.
  • If no, please set status-firefox118 to wontfix.

For more information, please visit BugBot documentation.

Flags: needinfo?(dharvey)

Comment on attachment 9351418 [details]
Bug 1848737 - Hide url in urlbar when action text shown. r=adw

Beta/Release Uplift Approval Request

  • User impact if declined: Visual glitch when user enters search mode
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: As per comment #1, visit a website, close tab, enter websites url then navigate to search mode
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): One line of CSS so unlikely to break things
  • String changes made/needed:
  • Is Android affected?: No
Flags: needinfo?(dharvey)
Attachment #9351418 - Flags: approval-mozilla-beta?
Flags: qe-verify+

Comment on attachment 9351418 [details]
Bug 1848737 - Hide url in urlbar when action text shown. r=adw

Approved for 118.0b6.

Attachment #9351418 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [qa-regression-triage] → [qa-regression-triage] [qa-triaged]
Attachment #9351418 - Flags: approval-mozilla-release?

Verified this issue with Firefox 119.0a1 (20230910212034) and Firefox 118.0b7 (20230910175934) on macOS 12 ARM, Windows 10 and Ubuntu 22.04 and it seems that the issue is fixed, when you are using "ctrl+down key" to navigate the toolbar's search engines.
If "alt+down key" (on Win 10/Ubuntu 22.04) or "option+down key" (on macOS ) are used to navigate them, then the issue is still reproducible.

Flags: needinfo?(dharvey)

Comment on attachment 9351418 [details]
Bug 1848737 - Hide url in urlbar when action text shown. r=adw

Not a new issue in 117. Let's aim for 118 instead so follow-up work based on QA's testing can also be addressed.

Attachment #9351418 - Flags: approval-mozilla-release? → approval-mozilla-release-

Its a similiar bug although not entirely sure if it should have been filed as a seperate new one, but put a patch up for review and will see

Flags: needinfo?(dharvey)

Actually didnt realise this was closed so will make a new one

Blocks: 1853456

Comment on attachment 9353480 [details]
Bug 1848737 - Show action correctly in restyled search results. r=dao

Revision D188383 was moved to bug 1853456. Setting attachment 9353480 [details] to obsolete.

Attachment #9353480 - Attachment is obsolete: true

The issue which can be reproduce, when "alt+down key" (on Win 10/Ubuntu 22.04) or "option+down key" (on macOS ) are used to navigate the toolbar's search engines, will be verified in 1853456. For now I'm closing this for easier tracking.
Thank you!

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: