Last Comment Bug 18505 - rename nsDeque::Peek() to nsDeque::PeekFront()
: rename nsDeque::Peek() to nsDeque::PeekFront()
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: XPCOM (show other bugs)
: Trunk
: All All
: P3 minor (vote)
: M13
Assigned To: Sammy Ford
: Suresh Duddi (gone)
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-10 14:16 PST by Chris Waterson
Modified: 1999-11-27 10:51 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Chris Waterson 1999-11-10 14:16:42 PST
...to be consistent with PushFront() and PopFront(). This nomenclature confused
both norris and jband, who assumed Peek() corresponded to Push() and Pop(), and
was the cause of bug 18408.

Also, implement a new nsDeque::Peek() which look at the end of the deque, and
corresponds to Push()/Pop().

rickg: does that make sense?

Note You need to log in before you can comment on or make changes to this bug.