Closed Bug 18508 Opened 20 years ago Closed 19 years ago

[RFE] way for user to set custom bindings

Categories

(Core :: DOM: UI Events & Focus Handling, defect, P3)

defect

Tracking

()

VERIFIED FIXED
mozilla0.9

People

(Reporter: ataylor+origacct, Assigned: akkzilla)

References

(Blocks 1 open bug)

Details

(Keywords: access, regression)

Attachments

(1 file)

Allow users to select their own key bindings.  In particular, it would be useful
to be able to use key bindings from one platform on another.  For example, the
ability to use the unix cursor movement keys (^f, ^b, ^n, ^p, etc.) in Win32.
Assignee: leger → don
Component: Browser-General → XPApps
QA Contact: leger → don
Target Milestone: M20
Setting component.
Move to "Future" milestone.
Target Milestone: M20 → Future
Since Don has left, Vishy is taking his bugs in bulk, pending reassignment.
thanks,
	Vishy
Assignee: don → vishy
nav triage team:

Not happening in beta1 timeframe, marking nsbeta1-
Keywords: nsbeta1-
QA Contact: don → sairuh
Component: XP Apps → Keyboard Navigation
giving to akkana, I can take if it needs an owner.
Assignee: vishy → akkana
Summary: {RFE] add optional unix (emacs) keybindings on all platforms → [RFE] add optional unix (emacs) keybindings on all platforms
We're waiting on hyatt (or his delegate), who told me a while ago that the
chrome/resource architecture was being revised so that we'd get back the
functionality we used to have of being able to specify a personal behavior file
for xbl widgets.  Once we get this, I'll be very happy to do whatever else needs
doing, but I haven't heard an update in a while on the state of the resource
redesign.

For now, you can do it by un-zipping the jar file containing
platformHTMLBindings.xml, adding the bindings you want (or simply replacing
platformHTMLBindings.xml with the Unix version) then re-zipping the jar.

Requesting beta1 re-evaluation, this isn't just for emacs bindings
(accessibility people want it to) and it's functionality we used to have, which
has regressed.  I can do at least some of the work if someone will update me on
the current plans.
Assignee: akkana → hyatt
OS: Windows NT → All
Summary: [RFE] add optional unix (emacs) keybindings on all platforms → [RFE] way for user to set custom bindings
Blocks: 57805
See bug 57805 for UI for these settings.
Taking this bug -- I have a patch.
Assignee: hyatt → akkana
Target Milestone: Future → mozilla0.9
Turns out that text controls already worked, but the syntax had changed (I have
the new syntax documented now in http://www.mozilla.org/unix/customizing.html).
This patch enables the same functionality for editor and browser windows.

Hyatt, could you sr this patch, please?  (Is there someone here willing to r it?)

In addition to adding the user bindings, there's some code factoring to
eliminate duplicate code.  One difference is that I changed the logic of
nsXBLSpecialDocInfo() using mFilesPresent and figuring out whether it's been
initialized or not, and I wasn't entirely clear on how mFilesPresent was being
used, so it's possible I might have missed something in the way I replaced it. 
Most of the rest of the changes should be very straightforward.
Status: NEW → ASSIGNED
Keywords: patch
sr=hyatt. Looks good!
Thanks -- it's in!
Status: ASSIGNED → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
okay, rubberstamp.
Status: RESOLVED → VERIFIED
Component: Keyboard: Navigation → User events and focus handling
Type: enhancement → defect
You need to log in before you can comment on or make changes to this bug.