Closed Bug 18516 Opened 21 years ago Closed 20 years ago

No default filename when saving image

Categories

(Core :: XUL, defect, P2, minor)

x86
Windows 98
defect

Tracking

()

VERIFIED DUPLICATE of bug 22861

People

(Reporter: mahjongg, Assigned: law)

Details

when right clicking on an image and using the "safe image as..." function
seamonky M10 does not fill in a default filename (which can be extracted from
the HTML code) and file format (.JPG .GIF .PNG etc..), as most other browsers
do.
Summary: No default filename when saving image
bug report #18404 gives more information about this bug.
Bug report #15805 seems to be the same bug for saving links.
Assignee: shuang → leger
Component: UE/UI → Browser-General
now using M11, bug has not been fixed yet.
Assignee: leger → trudelle
Component: Browser-General → XP Toolkit/Widgets
Changing to XP Toolkit / Widgets and reassigning.  This bug is very similar to
bug 18228 (same dialog, different command, I'd think).
Assignee: trudelle → sdagley
reassigning to sdagley for triage.
Status: NEW → ASSIGNED
looks to be a dupe of law's 19340, he'll check and mark as dupe if appropriate
This was fixed post M10 (but still broken on Unix).  See bug #16403.

I do need to remember to add support for the proper image file filters so I'll
leave this bug to track that detail.
Are you sure about the reference to 16403?  That one's summary "TAB doesn't go to
next text field"
Oops, It'd help if law was cc:'ed
Assignee: sdagley → law
Status: ASSIGNED → NEW
I had the right digits, but I guess the order is important.  Try #16043.  I've
reassigned this to myself, too (I thought you'd already done that).
Priority: P3 → P2
Target Milestone: M15
Not required for beta 1.
Status: NEW → ASSIGNED
QA Contact: claudius → sairuh
-> sairuh
Move to M16 for now ...
Target Milestone: M15 → M16

*** This bug has been marked as a duplicate of 22861 ***
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
verif.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.