Closed Bug 185233 Opened 17 years ago Closed 12 years ago

text-align: right has gap at end of line in print preview depending on character kerning (wobbly/misaligned print preview of RTL/Hebrew pages)

Categories

(Core :: Print Preview, defect, P3)

x86
All
defect

Tracking

()

RESOLVED WORKSFORME
Future

People

(Reporter: matthew.van.eerde, Unassigned)

References

Details

(Keywords: rtl, testcase)

Attachments

(4 files, 1 obsolete file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130

A block element with text-align: right and multiple lines of content will
display in Print Preview with ragged padding on the right edge depending on the
character content of the line.  This occurs only in Print Preview: the browser
looks OK, the printed page looks OK.

Reproducible: Always

Steps to Reproduce:
1. Create a <div style="text-align: right;">
2. Put some lines with <br>s between them and different content between lines
3. Go to Print Preview

Actual Results:  
Print Preview displayed the lines with correct content but the right-align did
not accurately align the right edges of each line.

Expected Results:  
The Print Preview should display similarly to the browser - the right edge of
the rightmost character in each line should be aligned.
Go to Print Preview on this attachment
Print Preview shows this wrong for me, too
Win2k SP3 - Mozilla 1.2.1
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130
Same problem on Linux with Mozilla 1.4b.
Confirming on WinXP 2003052808.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase
Priority: -- → P3
Target Milestone: --- → Future
There is this problem also for input type text:
<input style="text-align: right;" value="test">
*** Bug 244409 has been marked as a duplicate of this bug. ***
This problem effects Hebrew pages (and probably Arabic ones too), as those
usually include dir="rtl". The bug occurs even in pages that don't explicitly
specify text-align: right, therefore I'm adding this to the summary of the bug
to make it easier to find.

I'm also changing OS to All, see comment #3.

Prog.
OS: Windows 2000 → All
Summary: text-align: right has gap at end of line in print preview depending on character kerning → text-align: right has gap at end of line in print preview depending on character kerning (wobbly/misaligned print preview of RTL/Hebrew pages)
This bug looks very similar to bugs #140636 and #140759
I suppose they are closely related, and probably the same problem cause the 3 bugs.
Assignee: rods → core.printing
QA Contact: sujay
I see  a similar thing with Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O;
en-US; rv:1.7.5) Gecko/20041108 Firefox/1.0 - the Hebrew page looks fine on
screen, but when printing to PDF via Acrobat distiller the lines are jagged.
Attached image corrected screenshot
Attachment #166684 - Attachment is obsolete: true
Attached file Testcase using tables
Had problems with this bug for a while now. Added testcase using 
Mass-assigning the new rtl keyword to RTL-related (see bug 349193).
Keywords: rtl
I can't reproduce this any more (tested with print preview on Windows and print-to-pdf on Mac). Please reopen if this is still a problem in a trunk build.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.