Closed Bug 1852422 Opened 10 months ago Closed 10 months ago

Accept "Z" as a time zone in Date.parse

Categories

(Core :: JavaScript: Standard Library, enhancement, P3)

enhancement

Tracking

()

RESOLVED FIXED
120 Branch
Tracking Status
firefox120 --- fixed

People

(Reporter: vinny.diehl, Assigned: vinny.diehl)

References

(Blocks 1 open bug)

Details

(Keywords: dev-doc-needed, parity-chrome, parity-ie)

Attachments

(1 file)

The format 08/15/2015 12:00:00Z should be accepted and produce a result equal to 08/15/2015 12:00:00 GMT. "Zulu time" as it is called is a common format used in military and aviation and is accepted by V8 and Chakra.

The "Z" should directly follow the time with no whitespace necessary in between (however, whitespace is allowed).

I saw this mentioned in Bug 1760290 but that pertains to the YYYY.MM.DD format, so I decided to open a separate bug for this.

See Also: → 1760290
Assignee: nobody → vinny.diehl
Status: NEW → ASSIGNED
Pushed by arai_a@mac.com:
https://hg.mozilla.org/integration/autoland/rev/0d5209658cf4
Allow zulu time Date format r=arai
Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → 120 Branch
Blocks: 1274354
Duplicate of this bug: 682781
Keywords: dev-doc-needed
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: