Closed Bug 18532 Opened 20 years ago Closed 20 years ago

[Dogfood] [CRASH]: Opening an existing document and hitting return

Categories

(Core :: DOM: Editor, defect, P1, critical)

x86
Windows NT
defect

Tracking

()

VERIFIED WORKSFORME

People

(Reporter: bijals, Assigned: kinmoz)

References

Details

(Whiteboard: [PDT+][by 11/18])

Steps:
1) Launch Navigator
2) Go to http://Blues/users/bijals/publish/im/5plusimfeatures.htm
3) Click on FILE-EDIT PAGE option
4) When Composer comes up, hit the return key

Actual Results: Crash!

Expected Results: Able to modify existing document

Build Date/Platform: 1999111014 on WinNT
Summary: [Dogfood] Crasher: Opening an existing document and hitting return → [Dogfood] [CRASH]: Opening an existing document and hitting return
Target Milestone: M12
using 1999111108 build on win95, I was able to reproduce this one. I submitted a
talkback report -- but can't get to the server at the moment. Setting to m12
Whiteboard: [PDT+]
Putting on the PDT+ radar.
Call Stack:    (Signature = 0x00000013 267cfae5)
0x00000013
0x0264a1fc
nsStringArray::`vector deleting
destructor'
nsObserver::Release
    [d:\builds\seamonkey\mozilla\xpcom\ds\nsObserver.cpp, line 38]
nsObserver::Internal::QueryInterface
    [d:builds\seamonkey\mozilla\xpcom\ds\nsObserver.cpp, line 38]
nsProperties::QueryInterface
    [d:\builds\seamonkey\mozilla\xpcom\ds\nsProperties.cpp, line 65]
nsProperties::Internal::QueryInterface
    [d:\builds\seamonkey\mozilla\xpcom\ds\nsProperties.cpp, line 65]
nsObserver::Internal::AddRef
    [d:\builds\seamonkey\mozilla\xpcom\ds\nsObserver.cpp, line 38]
nsPersistentProperties::Save
    [d:\builds\seamonkey\mozilla\xpcom\ds\nsProperties.cpp, line 451]
nsPersistentProperties::Save
    [d:\builds\seamonkey\mozilla\xpcom\ds\nsProperties.cpp, line 451]
nsPropertyElement::QueryInterface
    [d:\builds\seamonkey\mozilla\xpcom\ds\nsProperties.cpp, line 512]
nsGenericFactory::SetDestructor
    [d:\builds\seamonkey\mozilla\xpcom\components\nsGenericFactory.cpp, line 56]
nsSupportsIDImpl::GetData
    [d:\builds\seamonkey\mozilla\xpcom\ds\nsSupportsPrimitives.cpp, line 45]
nsSupportsStringImpl::GetData
    [d:\builds\seamonkey\mozilla\xpcom\ds\nsSupportsPrimitives.cpp, line 120]
nsSupportsWStringImpl::QueryInterface
    [d:\builds\seamonkey\mozilla\xpcom\ds\nsSupportsPrimitives.cpp, line 158]
Severity: normal → critical
Priority: P3 → P1
Assignee: beppe → kin
Blocks: 12658
Status: NEW → ASSIGNED
Accepting bug. I can't seem to reproduce this in my debug build. I'll try again
when I pull a fresh source tree tomorrow.
Whiteboard: [PDT+] → [PDT+][by 11/18]
I can't reproduce this in my debug build. I believe bijals@netscape.com is going
to check if he can reproduce this.

If it's still a problem, I'll start looking into it tomorrow.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → WORKSFORME
I can't reproduce this in todays build. Marking WORKSFORME.
Status: RESOLVED → VERIFIED
verified in 11/17 build.
Works for me now.
You need to log in before you can comment on or make changes to this bug.