Closed Bug 185323 Opened 17 years ago Closed 17 years ago

Page will not load due to malformed meta refresh

Categories

(Core :: DOM: Navigation, defect, P2)

x86
Windows 2000
defect

Tracking

()

RESOLVED DUPLICATE of bug 170021

People

(Reporter: lohphat, Unassigned)

References

()

Details

(Keywords: testcase)

Attachments

(1 file, 1 obsolete file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021213
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021213

URL causes page to simply reload instead of loading applet.  Seems to be a bad
tag.  Works fine in IE 6.



Reproducible: Always

Steps to Reproduce:
1.load URL
Actual Results:  
Page will not load

Expected Results:  
applet should start.
Attached file Source of offending URL (obsolete) —
Well, from looking at the Page Source, it's either bad, or invalid, code.
(attaching source for second opinion).
Attached file testcase
Attachment #109319 - Attachment is obsolete: true
the meta html code is broken because the var is not populated, either it works
only on IE (VBSCript) or a server-side script doesn't work.
Then, should Mozilla handle this broken meta refresh tag better when it's badly
written (IE6 won't reload testcase for eg., NS4.8 reloads testcase) ?

Propose to move to Tech Evangelism though.
Assignee: idk → other
Component: Java-Implemented Plugins → Layout
Keywords: testcase
QA Contact: avm → ian
Priority: -- → P2
The web page in question has been rewritten and no longer has a meta refresh.

The meta refresh code no longer suffers from this problem, in any case. 
Anything past 1.3beta will ignore refreshes that leave the time and URL both
unspecified.

*** This bug has been marked as a duplicate of 170021 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Component: Layout → Embedding: Docshell
QA Contact: ian → adamlock
Resolution: --- → DUPLICATE
Summary: Page will not load. Works in IE w/same sun JRE 1.3.1_02 → Page will not load due to malformed meta refresh
You need to log in before you can comment on or make changes to this bug.