Closed Bug 1853444 Opened 7 months ago Closed 5 months ago

Add support for getting and setting sendOrder for WebTransport streams

Categories

(Core :: Networking, enhancement, P3)

enhancement

Tracking

()

RESOLVED FIXED
121 Branch
Tracking Status
firefox121 --- fixed

People

(Reporter: jesup, Assigned: jesup)

References

(Blocks 1 open bug)

Details

(Keywords: dev-doc-complete, Whiteboard: [necko-triaged], [wptsync upstream])

Attachments

(1 file)

The WebTransport WG recently added dynamic getting and setting of SendOrder; this is to support that. A patch to add it to the WPTs is under review currently

Allow dynamic changes to steram sendOrder to comply with updated
spec.

Severity: -- → S3
Priority: -- → P3
Whiteboard: [necko-triaged]

We'll land this once we've vendored neqo

Flags: needinfo?(rjesup)

There is an r+ patch which didn't land and no activity in this bug for 2 weeks.
:jesup, could you have a look please?
If you still have some work to do, you can add an action "Plan Changes" in Phabricator.
For more information, please visit BugBot documentation.

Flags: needinfo?(rjesup)
Flags: needinfo?(kershaw)

We'll land this when new neqo is ready.

Flags: needinfo?(kershaw)
Pushed by kjang@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a47a1ff34d2a
Set/Get SendOrder for WebTransportSendStreams r=kershaw,necko-reviewers,webidl,smaug

Backed out for causing failures on /webtransport/

[task 2023-10-30T19:02:54.719Z] 19:02:54     INFO - TEST-START | /webtransport/sendorder.https.any.sharedworker.html
[task 2023-10-30T19:02:54.760Z] 19:02:54     INFO - Closing window e9bb184a-ae79-4edb-892d-6dcf8e8c668e
[task 2023-10-30T19:02:58.906Z] 19:02:58  WARNING - wptserve cannot call write() after FIN
[task 2023-10-30T19:03:00.192Z] 19:03:00  WARNING - wptserve cannot call write() after FIN
[task 2023-10-30T19:03:00.193Z] 19:03:00  WARNING - wptserve cannot call write() after FIN
[task 2023-10-30T19:03:02.321Z] 19:03:02     INFO - 
[task 2023-10-30T19:03:02.321Z] 19:03:02     INFO - TEST-UNEXPECTED-PASS | /webtransport/sendorder.https.any.sharedworker.html | WebTransport client should be able to create and handle a bidirectional stream with sendOrder - expected FAIL
[task 2023-10-30T19:03:02.321Z] 19:03:02     INFO - TEST-INFO | expected FAIL
[task 2023-10-30T19:03:02.322Z] 19:03:02     INFO - 
[task 2023-10-30T19:03:02.323Z] 19:03:02     INFO - TEST-UNEXPECTED-PASS | /webtransport/sendorder.https.any.sharedworker.html | WebTransport client should be able to modify unset sendOrder after stream creation - expected FAIL
[task 2023-10-30T19:03:02.326Z] 19:03:02     INFO - TEST-INFO | expected FAIL
[task 2023-10-30T19:03:02.327Z] 19:03:02     INFO - 
[task 2023-10-30T19:03:02.327Z] 19:03:02     INFO - TEST-UNEXPECTED-PASS | /webtransport/sendorder.https.any.sharedworker.html | WebTransport client should be able to modify existing sendOrder after stream creation - expected FAIL
[task 2023-10-30T19:03:02.327Z] 19:03:02     INFO - TEST-INFO | expected FAIL
[task 2023-10-30T19:03:02.330Z] 19:03:02     INFO - 
[task 2023-10-30T19:03:02.330Z] 19:03:02     INFO - TEST-UNEXPECTED-PASS | /webtransport/sendorder.https.any.sharedworker.html | WebTransport sendorder should not starve a stream without sendorder - expected FAIL
[task 2023-10-30T19:03:02.330Z] 19:03:02     INFO - TEST-INFO | expected FAIL
[task 2023-10-30T19:03:02.330Z] 19:03:02     INFO - 
[task 2023-10-30T19:03:02.330Z] 19:03:02     INFO - TEST-UNEXPECTED-PASS | /webtransport/sendorder.https.any.sharedworker.html | WebTransport sendorder should starve a lower priority stream - expected FAIL
[task 2023-10-30T19:03:02.330Z] 19:03:02     INFO - TEST-INFO | expected FAIL
[task 2023-10-30T19:03:02.330Z] 19:03:02     INFO - 
[task 2023-10-30T19:03:02.331Z] 19:03:02     INFO - TEST-UNEXPECTED-PASS | /webtransport/sendorder.https.any.sharedworker.html | WebTransport sendorder should starve a lower priority stream, variant 2 - expected FAIL
[task 2023-10-30T19:03:02.331Z] 19:03:02     INFO - TEST-INFO | expected FAIL
Pushed by rjesup@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6ac3819ddc53
Set/Get SendOrder for WebTransportSendStreams r=kershaw,necko-reviewers,webidl,smaug

Backed out for causing wpt failures on sendorder.https.any.js.
This fails in multiple subtests. If you want to see all the failures related to this backout, you can check this link.

Flags: needinfo?(rjesup)
Flags: needinfo?(rjesup)
Pushed by rjesup@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c425a66740c6
Set/Get SendOrder for WebTransportSendStreams r=kershaw,necko-reviewers,webidl,smaug
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/43053 for changes under testing/web-platform/tests
Whiteboard: [necko-triaged] → [necko-triaged], [wptsync upstream]
Regressions: 1864013
Flags: needinfo?(rjesup)
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → 121 Branch
Upstream PR merged by moz-wptsync-bot

The patch removed some amount of WPT tests, was that intentional? I know you are investigating because of failures there, but I'd rather disable it via meta ini file rather than removing them, unless those tests are fully redundant 🤔

Flags: needinfo?(rjesup)

FF121 docs work for this done in https://github.com/mdn/content/issues/30481

Flags: needinfo?(rjesup)

I wrote that test which landed in an earlier patch; it isn't possible to reliably test in that way

You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: