Closed Bug 185368 Opened 22 years ago Closed 21 years ago

in addition to "Save Page As" there should be a "Save Copy of Page As" for dynamic pages

Categories

(Core Graveyard :: File Handling, enhancement)

x86
Windows 2000
enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: itsayellow, Assigned: law)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130

If you save a web page from a dynamically created source (e.g. especially
financial transactions, online receipts, etc.)  often times you'll get frames
that only contain an error message, because mozilla is still trying to load
information from the server, but the content has already expired.  In these
situations, really what you want is to save a copy of the whole webpage, which
looks like the webpage but isn't necessarily extremely correct from a document
source standpoint.  And all of the information would be local and not loaded
from an external server.  And it seems to me that it's not important to save
everything in a directory, like "webpage complete"  Most of the time I just want
to save all of the text and formatting in such a web page in a simple html file,
so that I can load it with any web browser and view it simply.

I tried to think of a good example URL, but I encounter this normally when doing
financial transactions.  Any bank, credit card, or online store that returns a
receipt in a frame will likely be involved.

What I do now to solve this problem is to "Copy" the whole webpage, open
composer, then "Paste" into composer and save that file as html.  It would be
nice if this could be automated into a "Save Copy of Page As" option

Reproducible: Always

Steps to Reproduce:
1. get an online receipt with frames
2. "Save Page As" , "Web page, html only"
3. Often the problem shows up with "Web page, complete" also

Actual Results:  
lots of empty frames with error messages complaining about expired content.

Expected Results:  
Save a copy of the page that does not depend on any external server.  Save it in
one simple html file
"Web page, complete" should be doing what you want.  If it's not, file bugs
against it, please.
I just don't want to generate a whole directory structure every time I'm saving
a simple online receipt.  It would be nice to have a version of "Save web page,
html  only" that keeps all text local.  I don't even care if the images are
broken (i.e. unreachable if I'm off-line).
->File handling
Assignee: asa → law
Component: Browser-General → File Handling
QA Contact: asa → petersen
Um... So "Save as Text"?  We have that too....
Hmmm.  I just tried save page as text with a bank transaction confirmation...I
ended up with an empty text file.  The web page loads a frame from a separate
file from the server, and I think that wasn't sourced into the text file.

Is there any way to make this a no-brainer for the user?  So that if you save
a page as "HTML Only" you know that you'll be able to see that page whether
you're online or not, just without images?

It would be nice to just know that, and not have to say, yes, well it will only
work without frames, or only with non-dynamic content, and in the end I better
try loading the local saved page just to see if it all worked.  With IE it just
saves and you don't have to worry.  Maybe a "save recursive" option that fetches
the html for each frame?
It seems like this is just an example of the difference between a
web-designer/nerd type person who wants to download the real, actual, correct
source of the page, and an everyday user, who just wants to see something that
looks like the page, but doesn't necessarily care about the structure.

All I'm suggesting is that there exists an option for the everyday user.  One
that doesn't necessitate downloading all of the images for the page too.
Well.... we have a "save page as source" for web designers and a "save page as
it looks" for the everyday user.  And the latter is the default.  How often does
an everyday user want to save the _text_ of the page but not the images (and
especially stylesheets; many pages today are unreadable without the stylesheets)
that came with it?  Not very many.
Perhaps the reported problem is a symptom of bug 115174, and the page isn't
being saved correctly because it is not being saved from the cache.  Also, if
the invoice/receipt/confirmation is in a frame, make sure you use "Save Frame
As..." in the frame containing the important data if you are saving as HTML
only.  "Save Page As, HTML only" will only save the frameset, not the frames.
WontFix?  There's a problem, but I don't think think a viable solution is proposed.
Viable solutions are:
1)Frames are already deprecated.
2)As a workaround when they are still used, web page, complete should work
(pending a bug 115174 fix.  Yes, I saw comment #2, but adding a third option
would be featuritis.)
3)For dynamic web pages, is a symptom of bug 115174, which should be fixed.
Therefore, I'd like to mark this bug resolved.  It's partly fixed, wontfix, and
invalid.
Comment two is not helpful for framed pages anyway, since saving them DOES
require creating a whole directory structure if you want the subframes saved.

WONTFIX.  If someone cares, an extension can be written to do what the original
poster asked for (basically reimplementing the persistence object).
Status: UNCONFIRMED → RESOLVED
Closed: 21 years ago
Resolution: --- → WONTFIX
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.