Mail should support gzipped (.gz) mail folders (at least for IMAP)

RESOLVED DUPLICATE of bug 76852

Status

MailNews Core
Backend
--
enhancement
RESOLVED DUPLICATE of bug 76852
15 years ago
9 years ago

People

(Reporter: Tobias Burnus, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
I share a IMAP directory with mutt where the older messages are gzip compressed
in order to save space.

Current result:
I can subscribe to the file incoming-2002-11.gz, but it only contains one
message: The .gz file itself.

Expected:
Mozilla would be able to read this .gz file and saves changes to this file in
the gzipped as well.

Comment 1

15 years ago
is this mozilla or IMAP server problem

Updated

14 years ago
Depends on: 234601
Product: MailNews → Core

Comment 2

12 years ago
I would really like to be able to gzip old mail folders to save space.  These are essentially folders that I don't plan on changing.  Currently I have over 2 Gb data in these old folders, and from time to time, I need to search them.

Here is my suggestion fwiw.

Add a new option in TBird's mail folder context menu, something like "make archive", which will convert the mail folder into a gzip file.  Possibly, for completeness, also have an "undo make archive" to revert a gzip'ed folder to normal.  Any folder that is gzip'ed should probably not be allowed to be added-to or deleted-from, and the UI should prevent anyone doing so.

The back-end would then have to be prepared to search thru archive folders as well as the regular ones.  Since the end-user made the choice to archive, it will be understood the searching will take a little longer.

Comment 3

10 years ago
Isn't this a dupe of bug 76852?

Comment 4

10 years ago
Looks like a dupe to me.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 76852
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.