spacebar loads first bookmark toolbar icon instead of doing page down on new browser windows

RESOLVED FIXED in Camino2.0

Status

Camino Graveyard
Accessibility
P3
minor
RESOLVED FIXED
15 years ago
9 years ago

People

(Reporter: peter royal, Assigned: Sean Murphy)

Tracking

(Blocks: 1 bug)

unspecified
Camino2.0
PowerPC
Mac OS X
Dependency tree / graph

Details

Attachments

(1 attachment)

1.04 KB, application/x-javascript
Details
(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021204 Chimera/0.6+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021204 Chimera/0.6+

The spacebar, when focus is not inside a form control element, can generally be
used as a pagedown function. on some new browser windows, the spacebar loads the
first bookmark toolbar item instead of doing a page down

Reproducible: Always

Steps to Reproduce:
1. make sure the bookmark toolbar is visible and has a bookmark for a site as
the first item
2. goto any webpage (google works well)
3. control-click a link and open that link in a new window
4. switch to the newly opened window (command-~)
5. hit the spacebar.

Actual Results:  
The first item in the bookmark toolbar loaded

Expected Results:  
paged down the current webpage

Comment 1

15 years ago
Works for me on 2002121104
(Reporter)

Comment 2

15 years ago
Just re-tested on 2002121404 and I still see my previous behavior. Will attach
prefs.js
(Reporter)

Comment 3

15 years ago
Created attachment 109310 [details]
Reporter's prefs.js

Comment 4

15 years ago
I can reproduce with Build 1217.
But it only happens if you hit the space bar before the page is entierely
downloaded.
There is anyway a strange focus around the first Bookmark in the toolbar which
disappears only when the page has been entierely downloaded.

To reproduce:
SET the preferences to CMD-Click opens a New Window (no problem with Tabs).

Open a new page with
http://bugzilla.mozilla.org/buglist.cgi?product=Chimera&bug_status=unconfirmed
Show the toolbar with at least 1 bookmark in it.
Cmd-Click on any link to open it in a new page
Look while the page is downloading that the focus is around the first bookmark
in the toolbar.
If the page has not entierely downloaded, hit the space bar and it will jump to
the page defined in that highlighted bookmark. Which is normal.

What's not normal is that the first bookmark in the toolbar is highlighted!
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

15 years ago
> There is anyway a strange focus around the first Bookmark in the toolbar which
> disappears only when the page has been entierely downloaded.

This happens if you have your Keyboard/Full Keyboard Access prefs set to focus
'Any control'. Cocoa is focussing the first button in the window content, which
happens to be the first item on the bookmarks toolbar. So in some sense, this
bug is expected behaviour.
Assignee: bryner → sfraser
(In reply to comment #5)
> > There is anyway a strange focus around the first Bookmark in the toolbar which
> > disappears only when the page has been entierely downloaded.
> 
> This happens if you have your Keyboard/Full Keyboard Access prefs set to focus
> 'Any control'. Cocoa is focussing the first button in the window content, which
> happens to be the first item on the bookmarks toolbar. So in some sense, this
> bug is expected behaviour.

Yes, this happens because full keyboard access is turned on. However, shouldn't
Camino recognize that this isn't what we REALLY want selected? Also, I don't
think there's any other way to get to the Bookmarks Toolbar with the keyboard
after it looses focus in this instance.
I would also add that this behavior (i.e. spacebar activating the first site in
the BmT) occurs if you hide Camino and then reactivate it. So to reproduce:
1. Make sure at least one Camino window is open and BM toolbar is showing
2. Hide Camino using either cmd-h or Camino->Hide Camino
3. Reactivate Camino by clicking its icon in the Dock
4. First BM in the toolbar has focus as evidenced by an aqua outline around it.
Also, after further testing:
If full keyboard access is turned on, pressing command-tilden (apple-~) when the
URL is selected in the toolbar gives focus to the Bookmarks Toolbar. Pressing
that key combination again actually switches to the next window.
Considering this is kind of against the expected behavior of that keystroke (it
should switch to the next window immediately), perhaps something should be done
about this?

Comment 8

13 years ago
Wow; that's weird.

Updated

12 years ago
Priority: -- → P3
Target Milestone: --- → Camino1.1
Upd: using nightly 2005071908 (v0.9a2), command-tilden no longer selects the
bookmark bar. Therefore, the bookmarks bar is now completely inaccessible using
the keyboard, even with universal access on.
P.S. I'm not sure if the OS has to do with this. I'm currently on 10.3.9. I have
the feeling that when I last reported about this, I was still on 10.2.8.
This WFM using Camino 1.0 and Mac OS X 10.4.5 and following the steps in comment 0.

Note that for me the location bar is selected when cmd-~ to the newly opened window.
QA Contact: bugzilla → accessibility
Right now, bug 310395 gets in the way of testing this.
Depends on: 310395
Assignee: sfraser_bugs → nobody

Comment 12

11 years ago
This WFM with the steps in comment 0.  Can anybody still see this, or did it get fixed somewhere along the line?

Comment 13

11 years ago
> This WFM with the steps in comment 0.  Can anybody still see this, or did it
> get fixed somewhere along the line?

I just had this happen on forums.mozillazine.org with a recent trunk build. This is the first time I've seen this though.

Comment 14

11 years ago
I've definitely been seeing this, but the STR in comment 0 definitely don't trigger it (anymore).  Some reliable STR would be very useful.
Keywords: qawanted

Comment 15

11 years ago
This may be a red herring, since it's quite hard to trigger, but I can repro consistently like this. Possible STR:

1. Have a page loaded.  Position your mouse over Camino's dock icon.
2. Cmd-L, return, IMMEDIATELY Cmd-H
3. Before the page finishes loading, click on Camino's dock icon to unhide it
(In reply to comment #15)
> This may be a red herring, since it's quite hard to trigger, but I can repro
> consistently like this. Possible STR:
> 
> 1. Have a page loaded.  Position your mouse over Camino's dock icon.
> 2. Cmd-L, return, IMMEDIATELY Cmd-H
> 3. Before the page finishes loading, click on Camino's dock icon to unhide it
> 
note that after the page finishes loading, the bookmarks toolbar loses focus. another way to do this:
1. cmd-L, enter a URL, press return
2. immediately after this, press tab (a delay will result in hitting the search field)
3. same as above, focus is lost after page load is complete
The steps in comment 15 and 16 reproduce this for me. Removing the qawanted keyword since we know how to reproduce this.
Keywords: qawanted

Comment 18

11 years ago
This is still quite rare on branch.  Bumping to 2.0.
Target Milestone: Camino1.1 → Camino2.0
Blocks: 383871
Please retest this in tomorrow (2008-09-20) Cm2-M1.9 nightly builds (especially on 10.4), since bug 152987 and friends have overhauled our keyboard loop.

Comment 20

9 years ago
I tested this in official nightly builds (2008-09-20) Cm2-M1.9, and
I confirmed that this bug has been fixed on 10.4.11.
With the 20080920 build, comment 15 and 16 work perfectly fine: focus is on content, spacebar scrolls down the page (10.5.5/Intel).
Marking this FIXED by bug 152987 and friends.
Assignee: nobody → murph
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.