Closed Bug 1854112 Opened 7 months ago Closed 6 months ago

Add showPicker method to <select> elements

Categories

(Core :: DOM: Core & HTML, enhancement)

Firefox 119
enhancement

Tracking

()

RESOLVED FIXED
121 Branch
Tracking Status
firefox121 --- fixed

People

(Reporter: lwarlow, Assigned: evilpie)

References

(Blocks 1 open bug)

Details

(Keywords: dev-doc-complete)

Attachments

(2 files)

Steps to reproduce:

The showPicker() method is a new addition to HTMLSelectElement which addresses a common request from web developers: programmatically showing the options picker. This is a natural progression from the <input> showPicker() method

<select id="select">
...
</select>
<button onclick="select.showPicker()">Show the options picker</button>

WHATWG Spec PR: https://github.com/whatwg/html/pull/9754

The Bugbug bot thinks this bug should belong to the 'Core::DOM: Core & HTML' component, and is moving the bug to that component. Please correct in case you think the bot is wrong.

Component: Untriaged → DOM: Core & HTML
Product: Firefox → Core
See Also: → 1767228
Assignee: nobody → evilpies
Blocks: html
Depends on: 1856097
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Just as an fyi I've also done the mdn work for this

https://github.com/mdn/browser-compat-data/pull/20852

https://github.com/mdn/content/pull/29406

Assuming the spec PR gets merged I'll mark those as a ready and I'm currently aiming for a Chrome 121 shipping target for it.

Attachment #9355908 - Attachment description: WIP: Bug 1854112 - Add showPicker method to <select> elements. → Bug 1854112 - Add showPicker method to <select> elements. r?emilio

There is an r+ patch which didn't land and no activity in this bug for 2 weeks.
:evilpie, could you have a look please?
If you still have some work to do, you can add an action "Plan Changes" in Phabricator.
For more information, please visit BugBot documentation.

Flags: needinfo?(evilpies)
Flags: needinfo?(emilio)
Flags: needinfo?(emilio)

The PR is still not merged, not sure if we want to land it before that.

Flags: needinfo?(evilpies)
Pushed by evilpies@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/96f778853da7
Add showPicker method to <select> elements. r=emilio
Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → 121 Branch

Did you want to nominate this for the Fx121 relnotes?

Flags: needinfo?(evilpies)

When I landed this initially, it looked to me like the spec PR was about to land, but now there is an ongoing discussion about the behavior in uncomposed documents and even concerns with the previous <input> showPicker method.

Depends on D192711

Thanks for the reminder, I am just about to make this method Nightly-only, so we won't need that.

Flags: needinfo?(evilpies)
Pushed by evilpies@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/a2534d8717d7
Make HTMLSelectElement showPicker method Nightly-only. r=emilio
Depends on: 1864030

Fyi the HTML spec PR just got merged. Happy to make a follow up issue to mark as stable if that's prefered.

(In reply to Luke from comment #15)

Fyi the HTML spec PR just got merged. Happy to make a follow up issue to mark as stable if that's prefered.

Yes, please. Thank you.

Depends on: 1865207

FYI MDN Docs work for this can be tracked on https://github.com/mdn/content/issues/30336. Very little needed since @Luke did all the work :-). Just addition to experimental features, and some review comments. I'm marking as dev-doc-complete as it's pretty much done.

See Also: → 1745005
See Also: → 1877148
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: