Closed Bug 1854452 Opened 7 months ago Closed 6 months ago

Temporarily disable some Tier 2 a11y_checks for Password Manager

Categories

(Toolkit :: Password Manager, task, P3)

task

Tracking

()

RESOLVED FIXED
120 Branch
Tracking Status
firefox120 --- fixed

People

(Reporter: ayeddi, Assigned: ayeddi)

References

(Blocks 1 open bug)

Details

(Keywords: access)

Attachments

(1 file)

We are working on enabling Tier 2 a11y-checks to ensure our products have basic accessibility built-in (bug 1692110) and before that, we need to prepare the existing code base. While we triage and investigate existent tests that would fail once the a11y-checks are enabled in the CI, we are going to skip the failing tests altogether and then handle each one of them individually.

This task is to skip with fail-if condition of the failing tests while we continue investigation into the reasons these tests failed and to be able to backtrack these tests once they're resolved. A separate task to investigate the failed Tier 2 a11y_checks will be filed for an appropriate component.

Tests affected:

FAIL	toolkit/components/passwordmgr/test/browser/browser_basicAuth_multiTab.js	Node is not focusable via the accessibility API		button	
FAIL	toolkit/components/passwordmgr/test/browser/browser_doorhanger_autocomplete_values.js	Node is not focusable via the accessibility API	password-notification-username-dropmarker	dropmarker	ac-dropmarker
FAIL	toolkit/components/passwordmgr/test/browser/browser_doorhanger_autocomplete_values.js	Interactive elements must be labeled	password-notification-username-dropmarker	dropmarker	ac-dropmarker
FAIL	toolkit/components/passwordmgr/test/browser/browser_doorhanger_submit_telemetry.js	Node is not accessible via accessibility API		image	
WARN	toolkit/components/passwordmgr/test/browser/browser_doorhanger_submit_telemetry.js	Unlabeled element removed before l10n finished		richlistitem	autocomplete-richlistitem -
FAIL	toolkit/components/passwordmgr/test/browser/browser_preselect_login.js	Interactive elements must be labeled		button	ac-settings-button

Jobs affected:

  1. test-linux1804-64-qr/opt-mochitest-browser-chrome-swr-a11y-checks-${1-7} (Try run)

Some Tier 2 accessibility checks for click events fired on controls that should be keyboard accessible and have valid labels were failing for this component. They were captured by testing/mochitest/tests/SimpleTest/AccessibilityUtils.js via bug 1692110. These failing tests should be temporarily skipped in the directory's browser.ini file while we investigate these failures. For all confirmed bugs individual defects should be filed.

When the individual test failures are resolved and the individual bugs are closed, remove the fail-if condition for a11y_checks from the appropriate files/sections to ensure better test coverage and to avoid regressions in a11y of these components.

Blocks: 1854454

We are working on enabling Tier 2 a11y-checks to ensure our products have basic accessibility built-in (bug 1692110) and before that, we need to prepare the existing code base. While we triage and investigate existent tests that would fail once the a11y-checks are enabled in the CI, we are going to skip the failing tests altogether and then handle each one of them individually.

This task is to skip with fail-if condition of the failing tests while we continue investigation into the reasons these tests failed and to be able to backtrack these tests once they're resolved.

Related bugs:

  • Disabling tests: meta bug 1848402
  • Investigation and remediation for components with disabled tests: meta bugs 1848394 and 1854227, Password Manager-specific meta bug 1854454
  • Explore capturing click events for a11y_checks: bug 1692110

Depends on D188911

Attachment #9354473 - Attachment description: WIP: Bug 1854452 - Temporarily disable some Tier 2 a11y_checks for Password Manager. r=serg,tgiles,sfoster,Jamie → Bug 1854452 - Temporarily disable some Tier 2 a11y_checks for Password Manager. r=sgalich,tgiles,sfoster,Jamie
Attachment #9354473 - Attachment description: Bug 1854452 - Temporarily disable some Tier 2 a11y_checks for Password Manager. r=sgalich,tgiles,sfoster,Jamie → Bug 1854452 - Temporarily disable some Tier 2 a11y_checks for Password Manager. r=sgalich,Jamie
Pushed by ayeddi@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c2a60a8fc2d3
Temporarily disable some Tier 2 a11y_checks for Password Manager. r=sgalich
Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → 120 Branch
Attachment #9354473 - Attachment description: Bug 1854452 - Temporarily disable some Tier 2 a11y_checks for Password Manager. r=sgalich,Jamie → Bug 1854452 - Temporarily fail-if some Tier 2 a11y_checks for Password Manager. r=sgalich,Jamie
Pushed by ayeddi@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e626bf417fb2
Temporarily fail-if some Tier 2 a11y_checks for Password Manager. r=sgalich
Status: REOPENED → RESOLVED
Closed: 7 months ago6 months ago
Resolution: --- → FIXED
Target Milestone: --- → 120 Branch
Flags: needinfo?(ayeddi)
Depends on: 1871491
No longer depends on: 1871491
See Also: → 1871491
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: