Closed Bug 1854531 Opened 7 months ago Closed 6 months ago

Temporarily disable one Tier 2 a11y_checks for Reader Mode

Categories

(Toolkit :: Reader Mode, task, P3)

task

Tracking

()

RESOLVED FIXED
120 Branch
Tracking Status
firefox120 --- fixed

People

(Reporter: ayeddi, Assigned: ayeddi)

References

Details

(Keywords: access)

Attachments

(1 file)

We are working on enabling Tier 2 a11y-checks to ensure our products have basic accessibility built-in (bug 1692110) and before that, we need to prepare the existing code base. While we triage and investigate existent tests that would fail once the a11y-checks are enabled in the CI, we are going to skip the failing tests altogether and then handle each one of them individually.

This task is to skip with fail-if condition of the failing test while we continue investigation into the reasons this test failed and to be able to backtrack this test once they're resolved. A separate task to investigate the failed Tier 2 a11y_checks will be filed for an appropriate component.

Test affected:

Result	Path	Error	Element ID	Element tagName
FAIL	toolkit/components/reader/test/browser_drag_url_readerMode.js	Node is not accessible via accessibility API	urlbar-input-container	hbox

Jobs affected:

  1. test-linux1804-64-qr/opt-mochitest-browser-chrome-swr-a11y-checks-${1-7} (Try run)

Some Tier 2 accessibility checks for click events fired on controls that should be keyboard accessible and have valid labels were failing for this component. They were captured by testing/mochitest/tests/SimpleTest/AccessibilityUtils.js via bug 1692110. These failing tests should be temporarily skipped in the directory's browser.ini file while we investigate these failures. For all confirmed bugs individual defects should be filed.

When the test failure is resolved and its associated bug is closed, remove the fail-if condition for a11y_checks from the appropriate file/section to ensure better test coverage and to avoid regressions in a11y of this component.

Blocks: 1854532

We are working on enabling Tier 2 a11y-checks to ensure our products have basic accessibility built-in (bug 1692110) and before that, we need to prepare the existing code base. While we triage and investigate existent tests that would fail once the a11y-checks are enabled in the CI, we are going to skip the failing tests altogether and then handle each one of them individually.

This task is to skip with fail-if condition of the failing tests while we continue investigation into the reasons these tests failed and to be able to backtrack these tests once they're resolved.

Related bugs:

  • Disabling tests: meta bug 1848402
  • Investigation and remediation for components with disabled tests: meta bugs 1848394 and 1854227, component-specific bug 1854532
  • Explore capturing click events for a11y_checks: bug 1692110

Depends on D188923

Attachment #9354485 - Attachment description: WIP: Bug 1854531 - Temporarily disable one Tier 2 a11y_checks for Reader Mode. r=Gijs,mtigley,niklas,Jamie → Bug 1854531 - Temporarily disable one Tier 2 a11y_checks for Reader Mode. r=Gijs,mtigley,niklas,Jamie
Attachment #9354485 - Attachment description: Bug 1854531 - Temporarily disable one Tier 2 a11y_checks for Reader Mode. r=Gijs,mtigley,niklas,Jamie → Bug 1854531 - Temporarily disable one Tier 2 a11y_checks for Reader Mode. r=Gijs,Jamie
Pushed by ayeddi@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/29dca16eee2e
Temporarily disable one Tier 2 a11y_checks for Reader Mode. r=Jamie,Gijs
Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → 120 Branch
Attachment #9354485 - Attachment description: Bug 1854531 - Temporarily disable one Tier 2 a11y_checks for Reader Mode. r=Gijs,Jamie → Bug 1854531 - Temporarily fail-if one Tier 2 a11y_checks for Reader Mode. r=Gijs,Jamie
Pushed by ayeddi@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e1cd513aa7e7
Temporarily fail-if one Tier 2 a11y_checks for Reader Mode. r=Jamie,Gijs
Status: REOPENED → RESOLVED
Closed: 6 months ago6 months ago
Resolution: --- → FIXED
Target Milestone: --- → 120 Branch
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: