file:/// URL does not work in <a href= tag when page loaded from Internet

CLOSED DUPLICATE of bug 84128

Status

SeaMonkey
General
CLOSED DUPLICATE of bug 84128
15 years ago
13 years ago

People

(Reporter: bradmcc, Assigned: asa)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130

file: URL does not work in <a href= tag when page loaded from Internet.

URL does work when page loaded from workstation local disk.

Page has a link:

<a href="file:///C|/bradmcc/cloud9/Bradsmap.html" target="smLocal">dell-1</a>

When I access the page on my local disk, the target page
comes up in a new browser window.  When I access the page
from the Internet (see URL, above) http://www.users.cloud9.net/~bradmcc/myentry.html
then nothing happens.

I have tried other permutations of the URL, like : or // instead of
///.  Nothing seems to work.

This page always works in Netscape 4.7X.

If you are wondering why I want this feature, this is my
"personal web portal" page -- my "instrument panel" (I have
a similar page for work).

The test links are labelled "dell-1" and "dell-2" in the page (near
top right, to left of clock Applet).  It dawned on me that
you don't have my local disk, so I added a link that does not
exist on my computer, either: "nowhere".  In Netscape 4.7X, this
pops up a new window and a File Not Found message; in Mozilla 1.2.1,
nothing happens.

Reproducible: Always

Steps to Reproduce:
1. load http://www.users.cloud9.net/~bradmcc/myentry.html
2x. click on "dell-1" or "dell-2".
3x. nothing happens in Mozilla 1.2.1. Window pops up with
http://www.users.cloud9.net/~bradmcc/Bradsmap.html in Netscape 4.7X
2. YOU SHOULD: click on "nowhere".
3. nothing happens in Mozilla 1.2.1. Window pops up with
File Not Found message in Netscape 4.7X

Actual Results:  
In Mozilla 1.2.1, nothing happens.  In Netscape 4.7X,
new window pops up, as explained above.

Expected Results:  
Pop up new browser window with either File Not Found message,
or displaying the page loaded from local disk.

I looked at previous bugs.  This seems a different problem,
because everything works correctly when I load the page
from my local disk.  The problem occurs with a file:///
URL link in a page loaded from the Internet (i.e., from http://...).

I am running Windows 2000 SP2.
blocked for security reasons, see tools/web development Javascript Console.
The no error message is bug 84128

*** This bug has been marked as a duplicate of 84128 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 2

15 years ago
v dupe
Status: RESOLVED → VERIFIED
(Reporter)

Comment 3

15 years ago
A developer responded to my bug report with the 
solution to my difficulty.

Find your all.js file
in your mozilla directory and change the 
line with "checkloaduri" from true to false.

The developer also said there is a security
loophole here, which I have not pursued (yet...),
but which you should be aware of if you
read this.
Status: VERIFIED → CLOSED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.