Print command and paper size preferences & rubbish in preferences file

RESOLVED DUPLICATE of bug 118563

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 118563
15 years ago
13 years ago

People

(Reporter: Dave Royal, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021212
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021212

Upgraded from 1.1a to 1.3a
Previous print commanf preference 'lpr -Plp9' lost, defaults to
lpr ${MOZ_PRINTER_NAME:+'-P'}${MOZ_PRINTER_NAME}
Also paper size reverts from A4 to letter
Changed printer and paper size: prints OK but settings lost on subsequent reload
of Mozilla

Rubbish in prefs.js:
user_pref("print.  8.27", "  8.27");
user_pref("print. 11.65", " 11.65");
user_pref("print.\\µÿ¿Ü:P7¦�¶@Ø÷q", "lpr -Plp9");
user_pref("print.\\µÿ¿Ü:ˆÅ¿�¶@PzÁ", "lpr -Plp9");
user_pref("print.\\µÿ¿Ü:˜£�¶@Ø÷q", "A4");
user_pref("print.printer_PostScript/default.print_edge_bottom", 4);
user_pref("print.printer_PostScript/default.print_edge_left", 4);
user_pref("print.printer_PostScript/default.print_edge_right", 4);
user_pref("print.printer_PostScript/default.print_edge_top", 4);
user_pref("print.printer_PostScript/default.p˜µÿ¿d¼i@PzÁXµÿ¿”µÿ¿�¶@PzÁ", true);
user_pref("print.printer_PostScript/default.p˜µÿ¿d¼i@Ø÷qXµÿ¿”µÿ¿�¶@Ø÷q", true);
user_pref("print.printer_PostScript/default.p˜µÿ¿¸½i@PzÁXµÿ¿”µÿ¿�¶@PzÁ", 1);
user_pref("print.printer_PostScript/default.p˜µÿ¿¸½i@Ø÷qXµÿ¿”µÿ¿�¶@Ø÷q", 1);
user_pref("print.tmp.printerfeatures.PostScript/default.can_change_num_copies",
true);
user_pref("print.tmp.printerfeatures.PostScript/default.can_change_orientation",
true);
user_pref("print.tmp.printerfeatures.PostScript/default.can_change_paper_size",
true);
user_pref("print.tmp.printerfeatures.PostScript/default.can_change_spoolercommand",
true);
user_pref("print.tmp.printerfeatures.PostScript/default.has_special_printerfeatures",
true);
user_pref("print.tmp.printerfeatures.PostScript/default.orientation.0.name",
"portrait");
user_pref("print.tmp.printerfeatures.PostScript/default.orientation.1.name",
"landscape");
user_pref("print.tmp.printerfeatures.PostScript/default.orientation.count", 2);
user_pref("print.tmp.printerfeatures.PostScript/default.paper.0.height_mm", 210);
user_pref("print.tmp.printerfeatures.PostScript/default.paper.0.is_inch", true);
user_pref("print.tmp.printerfeatures.PostScript/default.paper.0.name", "A5");
user_pref("print.tmp.printerfeatures.PostScript/default.paper.0.width_mm", 148);
user_pref("print.tmp.printerfeatures.PostScript/default.paper.1.height_mm", 296);
user_pref("print.tmp.printerfeatures.PostScript/default.paper.1.is_inch", true);
user_pref("print.tmp.printerfeatures.PostScript/default.paper.1.name", "A4");
user_pref("print.tmp.printerfeatures.PostScript/default.paper.1.width_mm", 210);
user_pref("print.tmp.printerfeatures.PostScript/default.paper.2.height_mm", 419);
user_pref("print.tmp.printerfeatures.PostScript/default.paper.2.is_inch", true);
user_pref("print.tmp.printerfeatures.PostScript/default.paper.2.name", "A3");
user_pref("print.tmp.printerfeatures.PostScript/default.paper.2.width_mm", 296);
user_pref("print.tmp.printerfeatures.PostScript/default.paper.3.height_mm", 279);
user_pref("print.tmp.printerfeatures.PostScript/default.paper.3.is_inch", true);
user_pref("print.tmp.printerfeatures.PostScript/default.paper.3.name", "Letter");
user_pref("print.tmp.printerfeatures.PostScript/default.paper.3.width_mm", 215);
user_pref("print.tmp.printerfeatures.PostScript/default.paper.4.height_mm", 355);
user_pref("print.tmp.printerfeatures.PostScript/default.paper.4.is_inch", true);
user_pref("print.tmp.printerfeatures.PostScript/default.paper.4.name", "Legal");
user_pref("print.tmp.printerfeatures.PostScript/default.paper.4.width_mm", 215);
user_pref("print.tmp.printerfeatures.PostScript/default.paper.5.height_mm", 253);
user_pref("print.tmp.printerfeatures.PostScript/default.paper.5.is_inch", true);
user_pref("print.tmp.printerfeatures.PostScript/default.paper.5.name", "Executive");
user_pref("print.tmp.printerfeatures.PostScript/default.paper.5.width_mm", 190);
user_pref("print.tmp.printerfeatures.PostScript/default.paper.count", 6);

Tried deleting all lines staring 'user_pref("print.' .. but same result

Reproducible: Always

Steps to Reproduce:
1. Press print button
2. Press properties
3. Change print command to "lpr -Plp9" and paper size to A4; OK, OK
4  Prints OK. 
5  Close and reopen Mozilla - new print command and paper size lost

Comment 1

15 years ago
bug 118563 is about papersize not being remembered.
Summary: Print command and paper size preferences & rubbish in preferences file → Print command and paper size preferences & rubbish in preferences file
so let's dup.

*** This bug has been marked as a duplicate of 118563 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 3

15 years ago
FYI: print related rubbish in preferences was the issue in bug 185588, a fix was
just checked in.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.