Closed Bug 185554 Opened 19 years ago Closed 18 years ago

"saving" dialog blocks UI

Categories

(SeaMonkey :: UI Design, defect)

x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 159107

People

(Reporter: gwalla, Assigned: bugzilla)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021212
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021212

The "Saving" dialog that pops up when saving a file takes over the UI. The UI in
any window belonging to the same Mozilla process will not repaint until the
"Saving" dialog closes itself.

Reproducible: Always

Steps to Reproduce:
1.Right-click on an image in a webpage or email, and "Save image as..."
2.Click OK in the "Save File" dialog
3.Wait for the "Saving" dialog to come up and turn black, and try to switch to
another open Mozilla window.

Actual Results:  
Once the "Saving" dialog has turned black (presumably because it is closing
itself), no Mozilla window will repaint. Changing focus to another Mozilla
window will cause the titlebar of that window to change color to show focus, but
the contents of that window (including chrome) will not "come forward".

Expected Results:  
Changing focus to another window should repaint that window, and UI should
remain responsive.

Classic theme. RedHat 7.3 with WindowMaker 0.80 on P3 1GHz w/ 1.5G RAM, 12G SCSI HD.
After more testing, it seems that the long wait before the dialogs close is 
caused by a large downloads.rdf file. Renaming downloads.rdf reduces the wait 
to nearly nothing. However, that doesn't explain why the UI is blocked during 
whatever operations are performed on downloads.rdf.

*** This bug has been marked as a duplicate of 159107 ***
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
Product: Core → Mozilla Application Suite
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.