Closed Bug 1856397 Opened 9 months ago Closed 8 months ago

Incompatible message bar should be an error, not a warning

Categories

(Toolkit :: Add-ons Manager, enhancement, P2)

enhancement

Tracking

()

RESOLVED FIXED
120 Branch
Tracking Status
firefox120 --- fixed

People

(Reporter: willdurand, Assigned: willdurand)

References

Details

(Whiteboard: [addons-jira])

Attachments

(1 file)

When an installed add-on is no longer compatible with the app version, it is (app) disabled and a message bar is displayed in about:addons. Currently, the message bar is a warning, which suggests the user can do something OR the add-on can be re-enabled. This isn't possible so it should probably be an error instead.

Assignee: nobody → wdurand
Status: NEW → ASSIGNED
Assignee: wdurand → nobody
Status: ASSIGNED → NEW
Whiteboard: [addons-jira]
Assignee: nobody → wdurand
Status: NEW → ASSIGNED
Pushed by wdurand@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/60c9b7e3efcb
Set "error" type to the incompatible message bar in `about:addons`. r=rpl
Severity: -- → N/A
Priority: -- → P2
Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → 120 Branch
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: