Closed Bug 185677 Opened 18 years ago Closed 18 years ago

mozilla mail/news hangs with msg "copying message to Sent folder"

Categories

(MailNews Core :: Networking: NNTP, defect)

x86
Windows 98
defect
Not set
critical

Tracking

(Not tracked)

VERIFIED WORKSFORME

People

(Reporter: allltaken, Assigned: sspitzer)

Details

(Keywords: hang)

User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2.1) Gecko/20021130

I wrote a reply to a newsgroup message cross-posted to 4 groups (that may be
irrelevant) and sent it. I think the send is complete, but have no way to know.
The composition window has shown "Copying message to Sent folder" for 5 minutes
now. How long does it take to copy a little message to the Sent folder? It may
be waiting for some kind of handshake from the server that never will arrive.
I'm using a dialup connection but the handshaking still shouldn't take nearly
this long. This happened before, msg sent but not copied to Sent.

Reproducible: Didn't try

Steps to Reproduce:
1. Write a reply to a newsgroup post
2. Send it (click on Send)
3.

Actual Results:  
The composition window hangs with the message "Copying message..." as stated above.


Expected Results:  
Mozilla should have sent the message, received whatever confirmation is
required, and then save the message to Sent---and these events should not take
forever.
Just got confirmation that the msg was sent, posted, and I read it in a news
window. But the composition window is still waiting to copy it to Sent.
Severity: normal → critical
Keywords: hang
This condition probably appears when the irc ping time or irc lag time is large.
I don't know how to measure msg transmission speed except by my experience on
irc that a ping time of a few seconds is pretty good, while a ping time of a
minute isn't so good and a time of 10 minutes is pretty bad. Other traffic no
doubt is comparably slowed, including handshaking between a news server and client.
What does IRC have to do with NNTP?  Two entirely separate protocols.
It's my most reliable measure of high or low internet traffic that would delay
communication between my pc and my news server in California. The traffic gets
very heavy in late afternoon and early evening. Downloads generally get slower too.
Confirming bug in the trunk builds from around last 2-3 days.
I'm hitting this bug on my IMAP account.

I'm testing both win32 and linux trunk builds (the latest one 2002121705).

Steps to reproduce:
1. Compose a message
2. Try to save it in the Drafts or send it

Mozilla hangs while trying to save a copy of the message to a folder - be it
Drafts, or Sent.

In situations where the message would be saved to the Sent folder on a POP3
account (so the folder is local, in the filesystem), Mozilla hangs too, so it
doesn't look like a network related problem.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Alexander) olo@altkom.com.pl  - John's bug is on copying to Local Folders
(since that's where NNTP defaults to), but you confirmed this bug based on IMAP?
 Not the same thing.  One obviously opens a file stream the hard drive, the
other, a network connection to the server.
I see hangs when copying/moving/saving messages to _any_ folders - IMAP, Local
Folders, folders from POP3 account (that are local too).
I had two hangs on sending mail yesterday---both times my crash protection
utility reported that the program wasn't responding, and I had to kill it. Today
it seems to work on a test message and several others that I sent, but when I
search the reported bugs with keywords "send hang", I get an error message and
am referred to a bug related to implementing javascript in Mozilla.

Besides the mail sending and saving problems, there's the question of why the
behavior of Mozilla is so erratic, messing up one day and working the next.

Any info on this?

We have also had the problems of mozilla crashes when it tries to copy the
message to the sent folder. If you take a long time to write a message it seems
that is looses the connection to imap. And then it tries to copy the message to
Send folder without understanding that the connection is lost.
I've noticed that this bug tends to exhibit itself after massive folder activity
-  copying/moving/filtering large amounts of messages (some race condition?). It
is not limited to such circumstances, though.

My mail setup involves mail account that's subscribed to many different mailing
lists, some of them high volume, and 40 KB worth of message filtering rules. The
tree structure of my IMAP and local folders is very large, too.
I cannot reproduce it any longer with builds from date >= 2002-12-27.

John T, Lasse, do you confirm?
I'm still using 1.2.1 (20021130), and haven't seen the problem for a while.
We are still using 1.2.1, and we now bcc ourselves when we send a mail and then
filter the message that are sent from ourselves into our send box. Never crashes
and is 10 times faster.
marking wfm, since it does for me, and seems to for everyone else.
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → WORKSFORME
verified

if you see this in the future, please open a new bug.

thanks!
Status: RESOLVED → VERIFIED
The problem is back, this time in the form of bug 206408.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.