Impossible to remove JavaScript Events in Composer

VERIFIED FIXED

Status

SeaMonkey
Composer
VERIFIED FIXED
16 years ago
14 years ago

People

(Reporter: Manuel Reimer, Assigned: neil@parkwaycc.co.uk)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [adt3])

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.1) Gecko/20020826

If I have created a link with JavaScript Events in Composer, then it's
impossible to remove this Events in the preferences-window

Reproducible: Always

Steps to Reproduce:
1. Open Composer
2. Press Ctrl+L to open Link-Window
3. Enter a Link-Text
4. Enter a URL
5. Click on "Advanced Edit"
6. Click on the Tab "JavaScript Events"
7. Select a Attribute
8. Enter a value
9. Close all Windows with OK
10. Click in your Link and press Ctrl+L again
11. Click on "Advanced Edit"
12. Select the tab "JavaScript Events"
13. Select the Event in the list and click remove
14. Close the Windows with OK again
15. Open the Properties for that Link again
16. If you check the "JavaScript Events" in "Advanced Edit" then the Event isn't
removed
Actual Results:  
The JavaScript-Event still exists. It's impossible to remove it with the
Preferences-Window

Expected Results:  
The JavaScript-Event should be removed after clicking on "Remove"

I have the same problem with Mozilla 1.2.1

Comment 1

16 years ago
-->brade for triage
Assignee: syd → brade

Comment 2

16 years ago
confirming; I see this on my debug mac build
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: nsbeta1
OS: Windows 98 → All
Hardware: PC → All
Composer triage team: nsbeta1+/adt3
Assignee: brade → jaggernaut
Keywords: nsbeta1 → nsbeta1+
Whiteboard: [adt3]
(Assignee)

Comment 4

15 years ago
Created attachment 114203 [details] [diff] [review]
Proposed patch

This fixes the code in EdAEJSEAttributes.js so that it matches the equivalent
code in EdAEHTMLAttributes.js

Comment 5

15 years ago
Comment on attachment 114203 [details] [diff] [review]
Proposed patch

r=brade
does EdAECSSAttributes.js have the same problem?
Attachment #114203 - Flags: review+

Comment 6

15 years ago
-->neil since he has a patch
Assignee: jaggernaut → neil
(Assignee)

Updated

15 years ago
Attachment #114203 - Flags: superreview?(sfraser)

Updated

15 years ago
Attachment #114203 - Flags: superreview?(sfraser) → superreview+
(Assignee)

Comment 7

15 years ago
Comment on attachment 114203 [details] [diff] [review]
Proposed patch

Low risk patch, just copied code from working tab of dialog.
Attachment #114203 - Flags: approval1.3?

Comment 8

15 years ago
Comment on attachment 114203 [details] [diff] [review]
Proposed patch

a=asa (on behalf of drivers) for checkin to 1.3 final.
Attachment #114203 - Flags: approval1.3? → approval1.3+
(Assignee)

Comment 9

15 years ago
Fix checked in.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
vrfy'd fixed --js event is removed from both the advance link properties dlg as
well as the source itself. tested with 2003.02.19.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.