Open Bug 1858122 Opened 10 months ago Updated 7 months ago

ETP Fingerprinters Blocking blocks api.geetest.com and static.geetest.com causing captcha in passport.bilibili.com couldn't load

Categories

(Core :: Privacy: Anti-Tracking, defect, P2)

defect

Tracking

()

UNCONFIRMED

People

(Reporter: Tom25519, Unassigned)

References

(Blocks 1 open bug)

Details

User Agent: Mozilla/5.0 (Android 10; Mobile; rv:109.0) Gecko/118.0 Firefox/118.0

Steps to reproduce:

ETP Fingerprinters Blocking blocks api.geetest.com and static.geetest.com
causing captcha in passport.bilibili.com couldn't load (You need to touch/click "短信登录" then input any valid format china mobile phone in "请输入手机号" first, for example, 13611111111, then click "获取验证码", under normal circumstance the captcha should pop-up. )

This issue happens when enable standard, strict and custom FTP with enable Fingerprinters blocking.

I test with 119.0b7 Beta and 120.0a1 Nightly, this bug doesn't reproduce, but it also reproduce on another mobile phone with Fenix 118.2.0.

Severity: -- → S3
Priority: -- → P2

Since Fenix 119.0 had been release, this bug doesn't reproduce any more.

Status: UNCONFIRMED → RESOLVED
Closed: 9 months ago
Resolution: --- → WORKSFORME

[Tracking Requested - why for this release]:

Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Oops, reproduce on Fenix 121.0, 122.0b2 and 123.0a1 (2023-12-20T04:06:32.826599577).

You need to log in before you can comment on or make changes to this bug.