Page Reload Fails to See Different "selected" Option

VERIFIED DUPLICATE of bug 46845

Status

()

Core
Layout: Form Controls
VERIFIED DUPLICATE of bug 46845
15 years ago
13 years ago

People

(Reporter: Jim Brooking, Unassigned)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021212
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021212

The referenced page collects information from the user in the form of a Select
box. The form containing the box sets a cookie with the value of the select box
and reloads the same page. When the page is reloaded, server-side code updates
the database with the selected information.

The "selected" option is therefore changed when the page is repainted (the
"selected" option is chosen by other server-side code). Yet Mozilla apparently
does not check the "selected" option when the page is reloaded, e.g., using the
"Page Through Questions" VCR buttons at the bottom of the web page.

This has been tried on MSIE 5.5 and works as expected.

Reproducible: Always

Steps to Reproduce:
1. In the "your answer" select box, choose any "answer" different from what's
there. The page will reload and show your chosen answer.
2. Use the VCR buttons below the select box to page around the tool: the answer
you chose stays the same, even though the "selected" option changes.
Actual Results:  
Last-selected answer ("Your answer" select box) stays the same even though
"selected" indicator changes from page to page.

Expected Results:  
Display correct "selected" option.

Comment 1

15 years ago
This appears to be the same problem we are having with Bugzilla and mid-airs.
After a mid-air, using the back button, then clicking the reload button, the
select options are not updated to reflect changes made to the bug moments before
the mid-air. This caused several undos on bug 185615 and bug 185547 yesterday,
where this bug's behavior was noted.

Conf & OS -> All
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All
er, no.

*** This bug has been marked as a duplicate of 46845 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

15 years ago
I read the report of which this bug is supposed to be a duplicate, but I 
confess I am not familiar enough with the internals of Mozilla to understand a 
lot of the discussion. 

It seemed that much of the discussion was about the effects of reloading a page 
and preserving data in form fields. The bug I'm reporting is not quite the 
same, at least from my naive viewpoint. In my case there is an internally 
generated reload, but the reloaded form fields are changed by server-side 
scripting before being sent to the browser. 

The bottom line, in my view, is that the browser rendering of the page does not 
accurately reflect the page's HTML (the "selected" option) after executing 
the "steps to reproduce" I initially reported.

I hope the "reopened" status of the purported duplicate bug 46845 means you are 
looking at this again. I guess I could program a workaround, but I've had 
enough trouble with this project that I'm not eager to dive back into my rats 
nest of code on that page.

Thanks for your consideration and for your good work with Mozilla.

Well.. The central issue is the following question:

  Should form values be preserved when a page is reloaded?

For example, if I type in a textfield and then the page triggers a programatic 
reload, should the text I typed be wiped out?

It may be a thought (to suggest on bug 46845) that only inputs whose values the 
user has explicitly changed should be restored....
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.