Closed Bug 1858801 Opened 9 months ago Closed 2 months ago

Consider to bring back option to show a spinning cursor while the page is loading

Categories

(Core :: DOM: Core & HTML, enhancement)

Firefox 119
enhancement

Tracking

()

RESOLVED FIXED
128 Branch
Tracking Status
firefox-esr115 --- unaffected
firefox124 --- wontfix
firefox125 --- wontfix
firefox126 --- wontfix
firefox127 --- wontfix
firefox128 --- fixed

People

(Reporter: adrian, Assigned: gregp)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:109.0) Gecko/20100101 Firefox/119.0

Steps to reproduce:

I set ui.use_activity_cursor to true a long time ago, because it is the logical thing to do: While a page is loading, an activity/loading-type cursor should be displayed.

Actual results:

Since upgrading to 119b6, the setting is apparently ignored and the normal cursor remains during any loading activity.

Expected results:

The loading/activity cursor should be used while a page is loading.

After some search this appears to have been an intentional change: bug1848896 / https://phabricator.services.mozilla.com/D187350 bug187350

WTH! Is there any chance this removal could be reverted? Especially considering how tiny this change is? I really do not want to have to look at the tiny loading indicator in the tab bar or the status bar when I had a nice indicator right at the cursor (which is usually right where I'm looking at)!

In fact, many years ago there was already a period of time where the activity cursor was not working - it was removed from the core, and then added back behind the ui.use_activity_cursor setting. See bug481359 from 15 years ago. I actually remember this one. It was (iirc) opened by a linux user who had problems ("tends to flicker too much") that might have been related to their window manager. And some of the comments are pure nonsense ("the spinner does move the mouse pointer one pixel left, and one pixel up. gross!") coming from once again broken environments (I guess bad cursors on some linux distro or bad custom cursors on windows, who knows). You know why I remember this so well even though it was 15 years ago? Because I compiled firefox myself to revert this annoying change back then! Yes, 21-year-old-me found it that annoying back then.

Then, looking at bug482985 that "fixed the aftermath" of said removal (which made me very happy, even though I'm a techie and coder, building Firefox myself was far from something I enjoyed doing), there are many VERY good reasons FOR keeping this setting (and maybe even enabling it by default again). Hopefully someone in the Firefox dev team agrees with those reasons and that it would be nice to restore the pref.

FWIW, I can understand that you want to remove complex functionality nobody uses. But this one? It's tiny. Let those who had this cursor for the last 20 years or longer keep it. We are used to it. Please, stop taking away things just for the sake of taking them away. Some people use them and miss them once they are gone. I'm sure I'm not the only one among all those Firefox users out there.

And just a small comment to avoid going too off-topic: I've NEVER used Chrome as a primary browser. In fact, I see Chrome as the "you get what Google wants for you, and that's it" browser. No customization, few settings. Firefox on the other hand was always the nice browser with plenty of settings, even if some are under-the-hood (aka "about:config"). Please keep this level of customizability, especially when there's no benefit from removing it (back to the "tiny change" I was talking to above ;))

Keywords: regression
Regressed by: 1848896

:gregp, since you are the author of the regressor, bug 1848896, could you take a look?

For more information, please visit BugBot documentation.

Flags: needinfo?(gregp)

Thank you for submitting this report. Setting the component and waiting for the developer's opinion about it.
If this is not the correct component, please feel free to change it to a more appropriate one.

Component: Untriaged → DOM: Core & HTML
Product: Firefox → Core

The more I'm using Firefox without this, the less I can understand why this was 1) removed and 2) disabled by default to begin with.

It's such a quality-of-life reduction / poor UX that one now needs to move their eyes from the exact place where they've been looking (typically the cursor because you just clicked a link or button triggering some action that involves loading a new page) up to the tab bar near the top.

Of course with a really modern webapp this is much of a problem because there are few full-page changes and loading indicators are often part of the page - but reality is that a large part (probably even the vast majority) of the Web is not new and shiny. And on an older site, not having an easy-to-notice indicator of loading activity, is really annoying.

Please bring this back. Put me on the list of people who remember this and hated it 15 years ago when the wait cursor was removed, then rejoiced when the ui.use_activity_cursor setting was added, though i too think the wait cursor should be on by default.

I occasionally use chromium as an alternative browser and this has been one of the things that bugs me the most about it, not having this feedback that the page is loading. The "busy" animation in the tab is just not eye-catching when you're focused on where you clicked, and it's immensely frustrating not to get any obvious, immediate response.

I'm way too tied to firefox to "rage-quit" now but luckily i do compile from source, i'll try reversing the above-linked patch. But please, please put this back in, even if you have to continue hiding it in about:config...

I echo the comments from others about bringing this small but exceeding useful feature back. The busy cursor is one of the things I value in Firefox that is lacking in other browsers. The busy cursor is way easier to see than a little animation in the tab way up at the top of the screen.

Type: enhancement → defect
Flags: needinfo?(gregp)
Type: enhancement → defect
Type: enhancement → defect
Status: UNCONFIRMED → RESOLVED
Closed: 4 months ago
Resolution: --- → INVALID

Why was this closed as invalid without even a comment?!

(In reply to Adrian from comment #7)

Why was this closed as invalid without even a comment?!

Sorry, I closed this as invalid because the current behavior works as expected after bug 1848896. I don't think "defect" is the right type for this issue if we want to keep it open; I however have trouble to change the type to "enhancement".

Status: RESOLVED → REOPENED
Type: enhancement → defect
Ever confirmed: true
Resolution: INVALID → ---
Summary: ui.use_activity_cursor no longer works → Consider to bring ui.use_activity_cursor back
Severity: -- → S3
Type: enhancement → defect
Type: enhancement → defect
Type: defect → enhancement
Keywords: regression
No longer regressed by: 1848896

For some reason, regressions can't be enhancements

Assignee: nobody → gregp
See Also: → 1848896
Summary: Consider to bring ui.use_activity_cursor back → Consider to bring back option to show a spinning cursor while the page is loading
Pushed by gp3033@protonmail.com:
https://hg.mozilla.org/integration/autoland/rev/e8f156027b86
Add ability to spin the cursor while the page is loading r=emilio,Gijs
Status: REOPENED → RESOLVED
Closed: 4 months ago2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 128 Branch

Since nightly and release are affected, beta will likely be affected too.
For more information, please visit BugBot documentation.

Regressions: 1901164
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: