Closed Bug 1858823 Opened 5 months ago Closed 5 months ago

Perma tier2 Error disabling address space randomization: Operation not permitted

Categories

(Core :: JavaScript Engine, defect)

defect

Tracking

()

RESOLVED FIXED
120 Branch
Tracking Status
firefox-esr115 --- unaffected
firefox118 --- unaffected
firefox119 --- unaffected
firefox120 --- fixed

People

(Reporter: noemi_erli, Assigned: cfallin)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

:cfallin, since you are the author of the regressor, bug 1855321, could you take a look?

For more information, please visit BugBot documentation.

Flags: needinfo?(chris)

Taking a look now!

The patches for bug 1855321 changed the tag bits on JIT-frame FP values,
but this test was not updated. This patch fixes the hardcoded
assertions.

Assignee: nobody → chris
Status: NEW → ASSIGNED
Pushed by iireland@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9861124ce67f
Fix regression in interpreter gdb test. r=iain

I believe the above patch should fix the observed regression.

Flags: needinfo?(chris)

Set release status flags based on info from the regressing bug 1855321

Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → 120 Branch
You need to log in before you can comment on or make changes to this bug.