Closed Bug 1858994 Opened 5 months ago Closed 1 month ago

Punycode is shown in history

Categories

(Firefox :: Address Bar, defect, P2)

Firefox 118
defect

Tracking

()

VERIFIED FIXED
123 Branch
Tracking Status
firefox123 --- verified

People

(Reporter: faveoled, Assigned: mseibert)

References

Details

(Whiteboard: [sng-scrubbed])

Attachments

(4 files)

Attached image punycode.gif

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:109.0) Gecko/20100101 Firefox/118.0

Steps to reproduce:

Visit https://рнидс.срб
Click on address bar emptiness, then click again

Actual results:

Cyrillic symbols are replaced to punycode in history

Expected results:

Cyrillic symbols are shown as they are

Component: Untriaged → Address Bar

We were able to reproduce this and it's still valid for the heuristic visit result.

Assignee: nobody → mseibert
Severity: -- → S4
Status: UNCONFIRMED → NEW
Type: enhancement → defect
Ever confirmed: true
Priority: -- → P2
Whiteboard: [sng-scrubbed]
Status: NEW → ASSIGNED
Attachment #9358922 - Attachment description: Bug 1858994 - Punycode is shown in heuristic result.r=mak → WIP: Bug 1858994 - Punycode is shown in heuristic result.r=mak
Attachment #9358922 - Attachment description: WIP: Bug 1858994 - Punycode is shown in heuristic result.r=mak → Bug 1858994 - Punycode is shown in heuristic result.r=mak
Pushed by mak77@bonardo.net:
https://hg.mozilla.org/integration/autoland/rev/e65fca949600
Punycode is shown in heuristic result.r=mak

Backed out for causing multiple failures.


Flags: needinfo?(mseibert)
Flags: needinfo?(mseibert)
Attachment #9358922 - Attachment description: Bug 1858994 - Punycode is shown in heuristic result.r=mak → WIP: Bug 1858994 - Punycode is shown in heuristic result.r=mak
Attachment #9358922 - Attachment description: WIP: Bug 1858994 - Punycode is shown in heuristic result.r=mak → Bug 1858994 - Punycode is shown in heuristic result.r=mak
Attachment #9358922 - Attachment description: Bug 1858994 - Punycode is shown in heuristic result.r=mak → WIP: Bug 1858994 - Punycode is shown in heuristic result.
Attachment #9358922 - Attachment description: WIP: Bug 1858994 - Punycode is shown in heuristic result. → Bug 1858994 - Punycode is shown in heuristic result.

There is an r+ patch which didn't land and no activity in this bug for 2 weeks.
:mseibert, could you have a look please?
If you still have some work to do, you can add an action "Plan Changes" in Phabricator.
For more information, please visit BugBot documentation.

Flags: needinfo?(mseibert)
Flags: needinfo?(mak)
Pushed by mak77@bonardo.net:
https://hg.mozilla.org/integration/autoland/rev/2ea989327044
Punycode is shown in heuristic result. r=mak
Flags: needinfo?(mseibert)
Flags: needinfo?(mak)
Status: ASSIGNED → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
Target Milestone: --- → 123 Branch
Regressions: 1874546

Reproducible on Firefox 118.0 on Ubuntu 22.
Verified as fixed on Firefox Nightly 123.0a1 on Ubuntu 22, macOS 12, Windows 10.

Status: RESOLVED → VERIFIED
Attached image Firefox123.0b2 Punycode

Ubuntu 22.04.3, Firefox 123.0b2.
Punycode can still be seen on History -> Manage History view (attached screenshot above)

I think there has been a miscomprehension, as the bug was in the Address Bar Component and thus it has been fixed in the Address Bar, not in the History views.

Sorry about that, I just filed https://bugzilla.mozilla.org/show_bug.cgi?id=1876738 to track the History views.

Attached image NotFixed

Address Bar still shows Punycode sometimes, e.g. when entering this url: https://.срб

That's either expected because it contains some invalid char, or it's an invalid URI, or it's a bug in the URL parser, as new URL("https://.срб").URI.displaySpec shows Punycode. If that URI is actually valid please file a separate bug in Network.

You need to log in before you can comment on or make changes to this bug.