Closed Bug 185990 Opened 17 years ago Closed 11 years ago

microsoft.com - font-size: xx-small unreadable in Linux

Categories

(Tech Evangelism Graveyard :: English US, defect, P2, minor)

x86
Linux

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: Hinsight4, Unassigned)

References

()

Details

(Keywords: top100, top500)

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021212
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021212

Opening www.Microsoft.com produces the microsoft home page, but it is squeezed
together really tight making the text unreadable and distorting the images.

Reproducible: Always

Steps to Reproduce:
1.Open Mozilla 1.3 alpha
2.Type www.microsoft.com in teh location bar or choose it from Debug, Verification.
3.The page appears distorted.

Actual Results:  
The page doesn't turn out like it should.  It is only a problem in this version
of Mozilla I believe, can't tell you on that one.  I know it isn't a problem
with Konquerer and IE.

Expected Results:  
It should have displayed the text and pictures just like the other browsers.

I am still running the Modern theme, but it does it the same on classic too.
Page looks good to me, can you attach a screenshot?

Build 2002121708, Windows 2000.
-> Browser-general
Assignee: adamlock → asa
Component: Embedding: Docshell → Browser-General
QA Contact: adamlock → asa
Attached image screenshot
screenshot with linux trunk 20021217

the page has this:
TD {font-family: Verdana,Arial,Helvetica; font-size: xx-small;}
Can't read it using IE6 either. There's virtually no rendering difference
between Mozilla and IE6 at 1024 x 768 using default settings for both. What
resolution and monitor size are you using?
my screenshot was from 1280x1024 on a 17" monitor.
the problem appears to be that Mozilla/Linux's font sucks.  This is because it's
using an outline scaled font.  An Xft build using truetype fonts looks a lot
better (font is the same size, just readable).

If you want to prevent Mozilla from using outline scaled fonts for such small
fonts, you can set the pref "font.scale.outline.min" in your prefs.js/user.js. 
The default is 6.  Raising it to 10 forced Mozilla to use bitmap fonts for the
Microsoft page, which look better.
Yah, the fonts on the site are extremely small, but that's apparently the way
Microsoft wants it, since that's what they're specifying in their style sheets
(xx-small).  The only suggestion I can personally give would be to use the "Text
Zoom" features in the View menu to try scaling everything up.
You really Really REALLY should turn on Mozilla's minimum font size preference.
Assignee: asa → susiew
Blocks: MS
Severity: normal → minor
Status: UNCONFIRMED → NEW
Component: Browser-General → US General
Ever confirmed: true
Priority: -- → P2
Product: Browser → Tech Evangelism
QA Contact: asa → zach
Summary: The text and whole page is incredibly smaller than any other pages, not this way with Konquerer or IE. → microsoft.com - font-size: xx-small unreadable in Linux
Version: Trunk → unspecified
-> evang500
Keywords: evang500
Those who find xx-small objectionable might be interested in bug 187256. That
patch has already been tested to improve the M$ home page considerably.
tech evang june 2003 reorg
Assignee: susiew → english-us
QA Contact: zach → english-us
Keywords: top500
Keywords: top100
Is this still an issue ?
1-Microsoft's home page CSS no longer includes xx-small anywhere

2-We floor xx-small at 9px, so as long as the user maintains an adequate default setting, xx-small should at least be readable
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.