Closed Bug 1860426 Opened 9 months ago Closed 9 months ago

Copy disabled despite selection existing in the content process

Categories

(Core :: DOM: UI Events & Focus Handling, defect)

Firefox 118
defect

Tracking

()

RESOLVED DUPLICATE of bug 1863246
Tracking Status
firefox119 --- affected
firefox120 --- affected

People

(Reporter: borger, Unassigned)

References

Details

Attachments

(1 file)

Steps to reproduce:

Ich habe bei Firefox seit einiger Zeit ein merkwürdiges Verhalten festgestellt. (seit etlichen Wochen, kann den Zeitpunkt nicht genau bestimmen). Ich habe Google als Startseite einrichte, auch für neue Tabs. Gebe ich da jetzt nichts zur Suche ein und gehe gleich über Lesezeichen auf eine andere Seite (im gleichen Tab), kann ich dort keinen Text kopieren (also mit der rechten Maustaste und Kontextmenü). "Kopieren" ist da ausgegraut. Egal welche Seite ich öffne. Das gleiche umgekehrt, wenn ich von der Google Home aus über Lesezeichen auf einer anderen Seite was einfügen möchte (z.B. in ein Suchfeld). Da ist "Einfügen" ausgegraut. Das gleiche passiert auch wenn ich zwischendurch auf Google gehe, nichts eingebe und die Seite per Lesezeichen wechsle. Mit den Tastenkombinationen der Tastatur funktionierts jedoch. Ich habe Firefox auch versuchsweise schon komplett neu installiert und mit neuem Profil, ohne Addons und Änderungen getestet. Hab letztens für ne Freundin einen nagelneuen Laptop eingerichtet. Firefox 118.0.2 installiert. Google als Startseite eingerichtet. Lesezeichen sind Amazon und Spotify. Ich starte den Firefox, gehe direkt von der Google Startseite zum Amazon Lesezeichen. Was soll ich sagen: "Kopieren" ist ausgegraut. Es liegt also nicht an meinem PC. Habe jetzt auf beiden Geräten Firefox 115 ESR installiert, da tritt das Problem nicht auf.

Component: Untriaged → Menus

Das Video zeigt einen ähnlichen Fall. Das ist immer wieder reproduzierbar.

I could reproduce the issue with Firefox 120.01a (2023-10-22) and 119.0 on Windows 10x64. The problem is that the issue is very intermittent.
Steps:

  1. Set google.com as homepage.
  2. Close and reopen Firefox.
  3. Go to a bookmark and select random text.
    Actual Result: The copy context menu option is disabled. Unfortunately, a regression range might be impossible due to intermittency until some reliable steps are found.
Severity: -- → S3
Status: UNCONFIRMED → NEW
Ever confirmed: true

I was able to reproduce it in Windows 10 x64 and Windows 11 x64. The problem must have occurred at some point in Firefox 116 or 117.

See Also: → 1761430

In version 115.3.1esr (64-bit) the problem does not exist!

Neil, are you able to check what's going on here? I guess the copy command does not get enabled but I don't know why that would be.

(I've tried to narrow the regression window several times but have been unsuccessful because it doesn't reproduce 100% of the time for me.)

Flags: needinfo?(enndeakin)

I can reproduce this fairly reliably. It looks like nsFocusManager::GetActiveBrowsingContextInChrome is returning null for some reason.

Flags: needinfo?(enndeakin)
See Also: → 1763900
Blocks: 1863246
Component: Menus → DOM: UI Events & Focus Handling
Product: Firefox → Core
Summary: Copy and Past Bug → Copy and Paste Bug (copy disabled despite selection in content process)

"Paste" is not part of this bug. I suggest title "Clipboard copy context menu entry is sometimes disabled despite currently-selected text".

Summary: Copy and Paste Bug (copy disabled despite selection in content process) → Copy disabled despite selection existing in the content process

@lexlexlex
That is not correct!
"Paste" is of course part of the problem. It also does not work or is deactivated.
The title is now incorrect!!!!!!!

(In reply to borger from comment #8)

@lexlexlex
That is not correct!
"Paste" is of course part of the problem. It also does not work or is deactivated.
The title is now incorrect!!!!!!!

Where/when how is paste disabled? The video does not show this, and I cannot reproduce the issue described in comment 0 (using a search field on a bookmarked item after going to google's homepage first).

Flags: needinfo?(borger)

(In reply to :Gijs (he/him) from comment #9)

(In reply to borger from comment #8)

@lexlexlex
That is not correct!
"Paste" is of course part of the problem. It also does not work or is deactivated.
The title is now incorrect!!!!!!!

Where/when how is paste disabled? The video does not show this, and I cannot reproduce the issue described in comment 0 (using a search field on a bookmarked item after going to google's homepage first).

You can work around it by Ctrl C then Ctrl V

if you Ctrl C then try right click Paste it is also grey'd out
so yes Paste is also broken

this has been going on for 3months plus how it has taken this long to be noticed amaze's me

(In reply to Shonk from comment #10)

(In reply to :Gijs (he/him) from comment #9)

(In reply to borger from comment #8)

@lexlexlex
That is not correct!
"Paste" is of course part of the problem. It also does not work or is deactivated.
The title is now incorrect!!!!!!!

Where/when how is paste disabled? The video does not show this, and I cannot reproduce the issue described in comment 0 (using a search field on a bookmarked item after going to google's homepage first).

You can work around it by Ctrl C then Ctrl V

if you Ctrl C then try right click Paste it is also grey'd out
so yes Paste is also broken

These steps aren't really anywhere near detailed enough for me to reproduce. If I ctrl+c and then right click somewhere, Paste is not greyed out for me. You seem to be suggesting it's broken 100% of the time - is that actually the case or no? Can you outline specific steps when paste is also broken?

(at the moment, it's also unclear to me that the copy and paste parts would even be the same bug, but maybe that'll be come clearer once we narrow down what the actual issue is with paste)

Flags: needinfo?(firefox)

The same issue as I described in comment 6 would affect cut, copy and paste and in fact any menu command that has its enabled state set from the child process.

What I'm not clear on is why a separate bug 1863246 was created that is the same bug. We should just mark this as a duplicate of that one since it has clearer steps to reproduce.

(In reply to :Gijs (he/him) from comment #11)

(In reply to Shonk from comment #10)

(In reply to :Gijs (he/him) from comment #9)

(In reply to borger from comment #8)

@lexlexlex
That is not correct!
"Paste" is of course part of the problem. It also does not work or is deactivated.
The title is now incorrect!!!!!!!

Where/when how is paste disabled? The video does not show this, and I cannot reproduce the issue described in comment 0 (using a search field on a bookmarked item after going to google's homepage first).

You can work around it by Ctrl C then Ctrl V

if you Ctrl C then try right click Paste it is also grey'd out
so yes Paste is also broken

These steps aren't really anywhere near detailed enough for me to reproduce. If I ctrl+c and then right click somewhere, Paste is not greyed out for me. You seem to be suggesting it's broken 100% of the time - is that actually the case or no? Can you outline specific steps when paste is also broken?

(at the moment, it's also unclear to me that the copy and paste parts would even be the same bug, but maybe that'll be come clearer once we narrow down what the actual issue is with paste)

Im not giving you steps to reproduce it
I was informing you it also affects paste
since you disputed that earlier

It happens at random

and when it does happen if you copy with Ctrl C then right click to paste its grey'd out
you can ofc Ctrl V to paste said text

Flags: needinfo?(firefox)

FWIW, I did not claim anything about Paste - I simply changed the bug as suggested in comment #7 because it seemed superficially correct to me. I still cannot reliably reproduce the issue here. Anyway, duping this to the bug where there is a more technical investigation seems reasonable to me.

Status: NEW → RESOLVED
Closed: 9 months ago
Duplicate of bug: 1863246
Flags: needinfo?(borger)
Resolution: --- → DUPLICATE
No longer blocks: 1863246
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: