Closed Bug 186053 Opened 18 years ago Closed 18 years ago

Context menu option to open selected text as URL

Categories

(SeaMonkey :: General, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 10080

People

(Reporter: strfry, Assigned: asa)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130

Some sites include URLs that are not enabled as links.  Current practice is to
select the text of the URL, right-click, Copy, open a new tab or window, Paste,
Go.  It would be slick to select the URL, right-click, and pick "Open in new
tab" or "Open in new window".  This could also be handy when selecting only the
first part of some deep link to attempt to get a more general page.

Reproducible: Always

Steps to Reproduce:
1. Select the text between the quotes: "http://www.foo.com/" 
2. Right-click.


Actual Results:  
A context menu with no "Go" or "Open" options to take you directly to foo.com.

Expected Results:  
A context menu with Go, Open in new tab, Open in new window.
Hey, no fair-- bugzilla turned my sample "text" into a link!
Just a FYI: you can select a plaintext link and simply drag 'n drop it to some
empty space on the tab bar (around the close button if you have many tabs open)
to open it in a new tab.


*** This bug has been marked as a duplicate of 10080 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.