URL (Back button) history is lost when .PDF files are viewed in separate Tab

RESOLVED DUPLICATE of bug 146143

Status

SeaMonkey
Location Bar
RESOLVED DUPLICATE of bug 146143
16 years ago
10 years ago

People

(Reporter: captain crispy, Assigned: Joe Hewitt (gone))

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0.0) Gecko/20020530
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0.0) Gecko/20020530

I don't know if this has been fixed in the latest release of Mozilla, but in
v1.0 there's a problem with Tabs.

View a link that is a .PDF file in one Tab, then switch to another Tab that is a
'non-.PDF' web page, then switch back to the .PDF file Tab.  When switching back
to the .PDF file Tab, the URL (Back button) history is lost and it is not
possible to back up to the previous link (web page) before the .PDF file was
selected for that Tab.

Normally, without multiple Tabs in one browser window it is possible to use the
Back button to view previous web pages after viewing a .PDF file link.

I haven't tested other file types viewed in Mozilla through plug-ins to see if
the same problem exists (ie. if Mozilla can view .DOC files with a Microsoft
Word plug-in and the same problem happening just like the 'Acrobat plug-in Tab
dilemma')

Reproducible: Always

Steps to Reproduce:
1.open two Tabs in one browser window
2.click through multiple web page links for each of the two Tabs (creating Back
button histories for both Tabs)
2.click in one of the Tabs that has a .PDF file link (which will open the
Acrobat plug-in to view the file)
3.click on the Tab separate from the '.PDF file' Tab
4.then click on the '.PDF file' Tab again
Actual Results:  
you will notice that Back button histories are deleted it is not possible to
select the Back button to view the page previous to viewing the .PDF file

Expected Results:  
fix it

if this is already fixed in later versions then please disregard this bug but I
haven't downloaded or used any Mozilla versions higher than v1.0

Comment 1

16 years ago
Please follow the bug-reporting guidelines. Mozilla 1.0 is far too old to report
bugs against now. Please also search bugzilla before submitting bug-reports.

*** This bug has been marked as a duplicate of 146143 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.