Closed Bug 1862208 Opened 4 months ago Closed 4 months ago

Matrix messages aren't shown anymore

Categories

(Chat Core :: Matrix, defect)

Thunderbird 120
defect

Tracking

(thunderbird_esr115 unaffected, thunderbird120 fixed, thunderbird121 fixed)

RESOLVED FIXED
121 Branch
Tracking Status
thunderbird_esr115 --- unaffected
thunderbird120 --- fixed
thunderbird121 --- fixed

People

(Reporter: freaktechnik, Assigned: freaktechnik)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

The de-XPCOM caused matrix prepareForDisplaying code break because it assumed things would be XPCOM wrapped, when they aren't. The function call then errors which leads to us never displaying the message.

Version: trunk → Thunderbird 120
Attachment #9361198 - Attachment description: Bug 1862208 - Fix display of Matrix messages. r=clokep → Bug 1862208 - Fix display of Matrix messages. r=#thunderbird-reviewers
Target Milestone: --- → 121 Branch
Attachment #9361198 - Attachment description: Bug 1862208 - Fix display of Matrix messages. r=#thunderbird-reviewers → Bug 1862208 - Fix display of Matrix messages. r=clokep

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/a0fe2ff39512
Fix display of Matrix messages. r=clokep

Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED

Comment on attachment 9361198 [details]
Bug 1862208 - Fix display of Matrix messages. r=clokep

[Approval Request Comment]
Regression caused by (bug #): bug 1857959
User impact if declined: Can not see any matrix text messages
Testing completed (on c-c, etc.): Tested on c-c, new automated test covering the issue.
Risk to taking this patch (and alternatives if risky): Low risk, only modifies matrix protocol which is already not working in a useful way.

Attachment #9361198 - Flags: approval-comm-beta?

Comment on attachment 9361198 [details]
Bug 1862208 - Fix display of Matrix messages. r=clokep

[Triage Comment]
Approved for beta

Attachment #9361198 - Flags: approval-comm-beta? → approval-comm-beta+
You need to log in before you can comment on or make changes to this bug.