On Mozilla startup, error message appears to not use the Sun JVM for IE (wo reason/annoying)

VERIFIED DUPLICATE of bug 83376

Status

()

defect
VERIFIED DUPLICATE of bug 83376
17 years ago
15 years ago

People

(Reporter: noplease, Assigned: rubydoo123)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

17 years ago
User-Agent:       Mozilla/5.0 (compatible; MSIE 6.0; de-DE; Windows XY) Gecko/20021120 Netscape6/6.23
Build Identifier: Mozilla/5.0 (compatible; MSIE 6.0; de-DE; Windows XY) Gecko/20021120 Netscape6/6.23

Found to happen on Win2000prof(SP3) and Win98SE(virgin setup):
Opening Mozilla 1.1 or 1.2.x and having a Sun-Java PlugIn 1.4.x (actually
happened with 1.4.1.01) properly installed, an annoying error message appears:
"You shall not use the Sun Java VM with InternetExplorer, use the VM of M$
instead" (freely translated from german language)
This error-message appears immediately after Mozilla's splash-screen and
prevents Mozilla from loading until clicking "OK". After clicking "OK" the
message-box disappears and Mozilla will load and work as usual.
This is independend whether an IE 5 or IE 6 SP1 is installed.
This is independent whether Sun-Java is the chosen VM for IE or not!
Enabling/disabling Java in Mozilla toggles behaviour... (disabling=no "error").
It does not happen if IE wasn't used anytime before on the concerned PC. Upon
first use/initializing IE, the "error" occurs upon every start of Mozilla. If
using 'Quickstart', it occurs as well when closing the last open Mozilla-Window.
It does not matter if Sun-Java is installed prior to using IE the first time or
not. It will happen...
On a concerned PC with Win2000prof(SP3) it occurs only when being logged in as
"adminstrator" - being logged in as "Username" with administrative rights
(member of admin-group) it does not happen, whyever. On the W98SE-machine there
is no chance to escape... it's always happening.
Maybe this is a kind of reminder to definitely not use IE even once - but how to
use "windowsupdate" without?
As nobody likes to disable and re-enable Java all the time this is no
workaround, too.

As this behaviour is new to me since Mozilla 1.1 and 1.2.1 (without changing
anything else) and changes with en-/disabling Java in Mozilla, I suppose it to
be a bugzillaworthy bug...
I searched bugzilla and didn't get any similiar bug report. If already existing,
please append, link or forgive me

Reproducible: Always

Steps to Reproduce:
1. Have your Win2000prof/Win98SE PC properly set up.
2. Install Mozilla (I tried 1.1 and 1.2.1 - installer) and make it
standard-browser/-mail-client (what else)
3. Goto Sun and fetch the JVM 1.4.x(1.4.1.01). Install it.
4. Start Mozilla
4a. If you haven't used IE 5/6 before, all seems to work fine
4b. If you already have used IE 5/6 (only needed to use windowsupdate ;-) ) you
should experience an error message popping up while Mozilla is loading.
...
5. Assure that JVM is not configured to be used by IE (control panel)
6. Assure that IE won't use Sun-JavaVM (Internet-Options)
7. Launch Mozilla and see it happening again!
8. Disable Java in Mozilla's preferences
9. Launch Mozilla and see no error occurring anymore.
10. Stop scratching your head to reduce loss of hair.
Actual Results:  
As long as Java is enabled in Mozilla, this annoying and sense-/useless error
message persists, giving me an error that 'IE should be configured to not use
Sun-Java...' if this is definitively already disabled/not in use.

Expected Results:  
Loading not showing me a only apparently IE-related error message without any
reason.
I could accept this message if the mentioned fact would be truth. The better way
would be to have this message coming upon IE-startup... so about twice a year... ;-)


I'm not the first one... 
For another "victim" (using jdk 1.3.1 & 1.4.0 on W2k-prof w/IE6SP1) visit:
http://article.gmane.org/gmane.comp.mozilla.devel.plugins/238

I'll make a screenshot available for some months on
http://home.arcor.de/noplease/images/JavaMoz.jpg

Comment 1

17 years ago
dup of bug 83376

This happens when the Jave plugin gets confused about the user agent string.
To avoid the error, revert to the real user-agent string instead of your
customized one.

*** This bug has been marked as a duplicate of 83376 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
Reporter

Comment 2

17 years ago
I apologize, R.K.Aa!
.
Being glad it was just a dup, but there were remarkable differences at first
sight. For this I believed in having some kind of similiar but different problem
leading me to post a bug!
.
Anyway remarkable:
I always used a "user.js" to modify settings, no direct "tweaking" in the
"prefs.js". The necessity of an unchanged UA in the "prefs.js" was well known to
me. Before I changed to Mozilla 1.1 everything worked fine...
.
BUT what I didn't expect to find was, that certain settings are now (unattended)
copied from "user.js" to the "prefs.js" by Mozilla itself!
This is new to me - seems to have changed somewhen, somehow.
.
Because of this, just removing any existing "user.js" including a pref to change
the UA (as I tried beforee) doesn't fix the problem. The UA-pref has 'moved' to
the "prefs.js" causing that the problem persists until this entry is deleted,
too - manually!
.
Additionally:
Why wasn't there a problem for weeks until I decided to run windowsupdate and
the IE got initialized by this? BANG! Since then I got this annoying "error",
not at any time before... Seems, this "error" depends on IE-usage having
Mozilla, too!
And: why does this error tell me something nonexistant? OK, that may be a
question to be answered by the folks of Sun...
.
.
Idea#1:
As the JVM-plugin is initialized during startup, look for a way to delay the
"override" until everything like the Sun-JVM has come up and perform this change
afterwards. If there is any way to re-enter the chosen value out of the prefs or
to keep it as variable until loading will finish, this might work.
.
Idea#2:
Ignore any prefs like that and add a "UA-manager" similiar to the existing
cookie-management (may propably share routines) including a general mail-setting
and a "per site UA responder" providing an universal value and single
site-settings. By this pages of "handicapped Webmasters" will stay accessible...
This would resolve a lot of conflicts when visiting sites that mess up with the
reported UA but are, beside that, behaving well.
.
.
I copied portions of this post as comment to Bug 83376
http://bugzilla.mozilla.org/show_bug.cgi?id=83376
.
Thank you & Merry Christmas!
.
Markus
.
P.S.: You shouldn't have messed with the UA of the machine, I've used to report
the bug! I'm operating several PC's and correspondance had taken place from
another than the affected one.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.