Closed Bug 1862404 Opened 9 months ago Closed 2 months ago

Scheme not properly shown on overflow by RTL domains

Categories

(Firefox :: Address Bar, defect, P3)

defect

Tracking

()

VERIFIED FIXED
128 Branch
Tracking Status
firefox128 --- verified
firefox129 --- verified

People

(Reporter: mseibert, Assigned: mak)

References

(Blocks 1 open bug)

Details

(Whiteboard: [sng])

Attachments

(2 files)

Attached image comparison.png

Steps to reproduce:

  1. Enable browser.urlbar.trimHttps
  2. Visit https://اختبار.اختبار.com/an/extra/long/rtl/url
  3. Scale down the window width, until the URL overflows.

The protocol should stay visible, when overflowing. However, when https trimming is enabled this is not the case. There is a special rule for not trimming https on RTL domains.

In the attached picture you can see the wrong overflow (trimHttps enabled) at the top and the correct overflow on the bottom (trimHttps disabled).

When trimHttps will be shipped, we will also show the "Not Secure" label along with the lock icon, so it may not be super critical anymore that we show the protocol.
This is likely an edge case due to the fact we don't trim RTL domains, to avoid changing their initial direction.

Severity: -- → S3
Priority: -- → P3
Assignee: nobody → mak
Status: NEW → ASSIGNED

The example in comment 0 is not the best because it's an invalid url, we can rather use
https://اسماء.شبكة/#%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%D7%A1%D7%95%D6%B9.%D7%A1%D7%97
and http://زخرفة.com/ for insecure connection.
That said, I think the behavior here doesn't make a lot of sense...
First of all, if security.insecure_connection_text.enabled is set, the indicator is clear enough, I don't think we need to show any additional protocol box, even if it's not visible.
I must note other browsers don't really mind anymore about showing the protocol, indeed they always trim.

Thus I think we may want to change the behavior a bit here.

Pushed by mak77@bonardo.net:
https://hg.mozilla.org/integration/autoland/rev/1248271f7473
Scheme not properly shown on overflow by RTL domains. r=dao
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 128 Branch

Issue is reproducible on a 2024-05-28 Nightly build on Windows 10, using the url from Comment 2.
Verified as fixed on Firefox 128.0b1 and Firefox Nightly 129.0a1 on Windows 10, Ubuntu 22, macOS 14.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: