Closed Bug 186283 Opened 17 years ago Closed 16 years ago

Browse zipfile/tarfile contents directly.

Categories

(Core :: Networking: File, enhancement)

enhancement
Not set

Tracking

()

RESOLVED DUPLICATE of bug 64286
Future

People

(Reporter: L.Wood, Assigned: dougt)

References

()

Details

It would be very useful if mozilla was capable of opening and
browsing tarfiles (and compressed tarfiles) and
their contents directly.

Non-unix platforms might already leverage available compression
engines to read proprietary compressed archives; e.g. the StuffIt
engine on MacOS.

This would be very useful for e.g. reading books from the Baen
Free library without uncompressing them, or mailing around prototype
website designs for convenient review.

I imagine resulting internal-to-tarfile urls might be of the form:
file:///local/blah/tarfiledir.tar.gz?tarfiledir/index.html
Changing summary as Severity=Enhancement already means that a new feature is wanted.
Summary: Feature request - browse zipfile/tarfile contents directly. → Browse zipfile/tarfile contents directly.
==> File
Assignee: asa → dougt
Component: Browser-General → Networking: File
QA Contact: asa → benc
related: bug 52282
would be nice.
Target Milestone: --- → Future
This is a duplicate of http://bugzilla.mozilla.org/show_bug.cgi?id=64286. Please
mark it as such and put in a vote for 64286 :)

Daniel

*** This bug has been marked as a duplicate of 64286 ***
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.