[PP]New Cards added to Address books are not seen when doing Autocomplete

VERIFIED DUPLICATE of bug 16354

Status

SeaMonkey
MailNews: Address Book & Contacts
P3
normal
VERIFIED DUPLICATE of bug 16354
19 years ago
14 years ago

People

(Reporter: esther, Assigned: hangas)

Tracking

({platform-parity})

Trunk
PowerPC
Mac System 8.5
platform-parity

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Using build 1999111011M11 on Mac only, if you add a new card to your Personal
Address Book or click on a message that adds a new card to your "Collected
Addressses" book, these cards are not seen when doing an Autocomplete in a
Compose window in the same session.  If you add these cards then close the app,
they are seen when doing an autocomplete.

1. Launch Messenger
2. Open the Address book and add a unique card to your Personal Address Book
(one will not partially or fully match a card in your current Personal Address
book or History book and does not end in @netscape.com, (i.e. Name=xzt and
e-mail = xztf@xxxx.com) hopefully you don't have this card already in your
Abook!  OK the card and check to see that it is listed in the right pane of the
address book when the Personal Address Book is selected.
3. Close the Address book
4. Click New Ms, in the To: field type in xzt then press <enter>

Result: the To: line autocompletes with xzt@netscape.com
Expected: the autocomplete of the unique name in your Personal Address book (xzt
<sztf@xxx.com> on the To: line

Note: if you close the app then repeat 1 & 4 the name will auto complete as
expected.
Also note: the same happens to the Collected Addresses abook if you have added a
unique new name then try to autocomplete before closing app.
(Reporter)

Updated

19 years ago
QA Contact: lchiang → esther

Comment 1

19 years ago
Esther, can you add a note in the tracking bug for M11 release notes for this?
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M12
(Assignee)

Comment 2

19 years ago
JF: any ideas here?  I will take this bug for now, but I cannot imagine what
would be causing it.
Totally normal, the TEMPORARY autocomplete code cache the whole AB content the first time is invoked. Therefore
new AB entries won't be accessible.

Paul, we need to figure a patch. I need somehow to know if the content of the AB is different than last time I cache
it, then I would be able to reset the cache. We need a cache for speed issue... Maybe you can keep a "content version"
number  that you  increase each time the content change.
(Reporter)

Comment 4

19 years ago
Added to M11 release notes 11/12/99
(Assignee)

Comment 5

19 years ago
Mass move to M13.

Comment 6

19 years ago
Let's not spend any more time than necessary on the temporary autocomplete code.
JF has the bug for the real implementation of autocomplete.
(Assignee)

Comment 7

19 years ago
Should we close this bug?
(Assignee)

Updated

19 years ago
Target Milestone: M13 → M14
(Assignee)

Comment 8

19 years ago
Moving to M14.

Updated

19 years ago
Keywords: pp

Comment 9

19 years ago
Yes, I think we should close this. Marking a dup of the real autocomplete
feature bug.


*** This bug has been marked as a duplicate of 16354 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 10

19 years ago
Verified as dup
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.