Two problems with title 'tooltips'

VERIFIED DUPLICATE of bug 45375

Status

()

VERIFIED DUPLICATE of bug 45375
16 years ago
15 years ago

People

(Reporter: bugzilla, Assigned: asa)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020826

Text in 'tooltips' (title property) is truncated after only a few characters,
and replaced with "...". All the text should be displayed (at least up to a
reasonable limit), preferably wrapped into medium-length lines (as seen in Opera
6 / IE).

Also, when the mouse is moved over a 'tooltip' that is over an image, the
onMouseOut event for that image is triggered, even if the tooltip is displayed
over the image. 

Reproducible: Always

Steps to Reproduce:
1. In the URL given above, move the mouse over a word in bold (ex., "locked") to
see a long tooltip being truncated.

2. In the same URL, move the mouse over an image to trigger onMouseOver, then
wait for the tooltip, then move the cursor over the tooltip.

Actual Results:  
1. Tooltip is truncated.

2. onMouseOut is triggered for that image.

Expected Results:  
1. Display the full text.

2. Trigger onMouseOut only when the cursor actually moves outside of the image.
(Reporter)

Comment 1

16 years ago
*** Bug 186361 has been marked as a duplicate of this bug. ***
please only one issue / bug report

*** This bug has been marked as a duplicate of 45375 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

16 years ago
Bug 45375 does not mention the second issue (tooltip triggering onMouseOut even when cursor is still over the image).
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 4

16 years ago
About issue 2, is that a bug? All other browsers behave the same.
Component: Browser-General → XP Toolkit/Widgets
(Reporter)

Comment 5

16 years ago
Other browsers trigger a redraw, but not a MouseOut event. This can be seen on the URL provided: move the cursor over one image, it enlarges (triggered by onMouseOver). Move the cursor to the centre of the image, wait for the tooltip to be displayed. Now pass the cursor over the tooltip, and the image shrinks again (triggered by onMouseOut), although the cursor never actually moved out of the image. Can anyone check if this happens only in Windows or in other operating systems as well?
Rui del-Negro: Bugs with 2 problems/bug report are invalid. File a new bug for
the second problem

*** This bug has been marked as a duplicate of 45375 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE
verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.