Closed Bug 186446 Opened 18 years ago Closed 18 years ago

making Mozilla default browser also affects associations for graphics files

Categories

(SeaMonkey :: Preferences, enhancement)

x86
Windows 98
enhancement
Not set

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 131106

People

(Reporter: river, Assigned: bugs)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3a) Gecko/20021216
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3a) Gecko/20021216

I had all my graphics file types set up with File associations to give me a
choice of several programs to view/edit pictures.  When I set Mozilla as my
default browser the gecko ate them all up.

There are two issues that arise

(1)
I did not expect Mozilla to do anything at all to my graphics files,  which I
use for publishing not for webby stuff

Please could you add another question to the dialog with the possible answers
- make Mozilla the default to view graphics
- only make Mozilla the default for HTML files

(2)
Even for the .html file associations,  I did not expect Mozilla to zap the
right-click options it does not use.  For example I had a custom "open with
Notepad" option for my .html files.  There is no reason at all from my
perspective as a user why I should need to set that up again just because I
invited the gecko to change the "open" option.

Please consider whether it would be feasible to copy in all the right-click
options set up for those files and that Mozilla is not going to define.

I have listed this as an enhancement rather than a bug as clearly the software
is doing what the designers intended.  However from my perspecitve it does feel
like a bug as I did not want, nor was warned, about the side effects on my
desktop publishing when I only asked to change my browser.

Reproducible: Always

Steps to Reproduce:
1. Get a MS-Windows machine
2. Set Mycustom action in file associations for .jpg files so you see Mycustom
as an option when you right-click on .jpg files in Windows
3. Click on Set Preferences -> Make Mozilla Default Browser

Actual Results:  
Next time you right click on the .jpg file you no longer see Mycustom as an option

Expected Results:  
Asked before altering the settings for graphics files, and even then changed the
Open option only, preserving the rest of the right click menu.

*** This bug has been marked as a duplicate of 131106 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
v dup
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.