Closed Bug 18654 Opened 20 years ago Closed 20 years ago

bugzilla main screen doesn't display correctly

Categories

(Core :: Layout: Tables, defect, P3, critical)

x86
Linux
defect

Tracking

()

VERIFIED WORKSFORME

People

(Reporter: colin, Assigned: karnaze)

Details

I have completely up to date M11 code (as of early morning Nov 12) and
have this built and running on OpenVMS. I noticed that whenever I went
to http://bugzilla.mozilla.org/ that the image of the bug didn't display.
Upon closer analysis the part that usually appears in the bottom right
(where you can enter a bug number or click on some other bugzilla
related links) wasn't there either. At first I thought this was an OpenVMS
problem since on my Linux box everything was fine.

I downloaded the latest (1999111108) Linux build and still the bugzilla
page was displaying fine. But after some more playing, I was able to reproduce
this problem on my Linux box. I can not reproduce the problem reliably, but
if I keep doing various combinations of the following, it will eventually
either make the problem appear or fix it (ie. it toggles the state of the
bug):

  - resize the window
  - do a SHIFT-RELOAD (don't think SHIFT is hooked up, is it?)

Sometimes it takes MANY (like a hundred) tries before the bug state will
toggle, so I don't know if only one of the above is needed to trigger it,
or some combination.

I've just been trying some more, and it seems that it takes less attempts
to toggle the problem ON that it does to toggle it OFF.

When the page is displayed incorrectly, I can do a VIEW SOURCE and see
that all the HTML is present.

This is weird. I hope someone else can reproduce it, cos I feel like I'm
going crazy here.
Assignee: troy → karnaze
Component: Layout → HTMLTables
I just picked up today's changes by nisheeth and rods and things are MUCH
better. Each time I access the main bugzilla page, or reload it, the bug image
appears.

One (new) oddity remains. The first time I display the page, about half the bug
image is cropped (ie. its positioned too far to the right). There are no
horizontal scroll bars so there is no way to see the right half of the bug.
Click in RELOAD and everything reflows and now the bug image is positioned
correctly. This is very repeatable.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → WORKSFORME
Works fine for me with the latest build
Works for me, too. This should now be closed.
Status: RESOLVED → VERIFIED
Works for me using the Dec 15th build (1999121508).
You need to log in before you can comment on or make changes to this bug.