Closed Bug 1866373 Opened 5 months ago Closed 5 months ago

firefox 120 on nixos crashes opening discord.com

Categories

(Core :: Widget: Gtk, defect, P2)

Firefox 120
defect

Tracking

()

RESOLVED DUPLICATE of bug 1861365

People

(Reporter: m.viey, Unassigned)

References

Details

Attachments

(1 file)

8.33 KB, text/plain
Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:120.0) Gecko/20100101 Firefox/120.0

Steps to reproduce:

open firefox 120 from a fresh upgraded on sway(wayland) / nixos

Actual results:

Any time I try to open this site. The browser crashes. I tried with FF120 from mac os it works. So maybe an issue with wayland.

Expected results:

Browser should not crash. At least only tab should crashes with an error message.

I tried from command line and reproduces the crash. Last messages appear just before the crash.

$ firefox
[Parent 17930, Main Thread] WARNING: Failed to call GetIdletime(): GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.Mutter.IdleMonitor was not provided by any .service files
: 'glib warning', file /build/firefox-120.0/toolkit/xre/nsSigHandlers.cpp:187

** (firefox:17930): WARNING **: 23:26:36.308: Failed to call GetIdletime(): GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.Mutter.IdleMonitor was not provided by any .service files

ExceptionHandler::GenerateDump cloned child 18428
ExceptionHandler::SendContinueSignalToChild sent continue signal to child
ExceptionHandler::WaitForContinueSignal waiting for continue signal...
Exiting due to channel error.
Exiting due to channel error.
Exiting due to channel error.
Exiting due to channel error.
Exiting due to channel error.
Exiting due to channel error.
Exiting due to channel error.

The Bugbug bot thinks this bug should belong to the 'Core::Widget: Gtk' component, and is moving the bug to that component. Please correct in case you think the bot is wrong.

Component: Untriaged → Widget: Gtk
Product: Firefox → Core

Can you please test latest nightly?
https://fedoraproject.org/wiki/How_to_debug_Firefox_problems#Testing_Mozilla_binaries

Also is that a recent regression?
Thanks.

Flags: needinfo?(m.viey)
Priority: -- → P2

(In reply to Martin Stránský [:stransky] (ni? me) from comment #3)

Can you please test latest nightly?
https://fedoraproject.org/wiki/How_to_debug_Firefox_problems#Testing_Mozilla_binaries

Also is that a recent regression?
Thanks.

yes it's recent. Just after an upgrade. I tried with new profile too.

I am going to try with nightly nixos version.

Thank you

Flags: needinfo?(m.viey)

(In reply to Martin Stránský [:stransky] (ni? me) from comment #3)

Can you please test latest nightly?
https://fedoraproject.org/wiki/How_to_debug_Firefox_problems#Testing_Mozilla_binaries

Also is that a recent regression?
Thanks.

Only beta version is available on nix.
Following your instruction I got an error launching firefox

[mik@labo:~/Downloads/firefox]$ ls
application.ini     firefox-bin      libfreeblpriv3.so     libmozsqlite3.so  libsmime3.so       platform.ini
browser             firefox-bin.sig  libgkcodecs.so        libmozwayland.so  libsoftokn3.so     precomplete
crashreporter       firefox.sig      libipcclientcerts.so  libnspr4.so       libssl3.so         removed-files
crashreporter.ini   fix_stacks.py    liblgpllibs.so        libnss3.so        libxul.so          Throbber-small.gif
defaults            fonts            libmozavcodec.so      libnssckbi.so     libxul.so.sig      updater
dependentlibs.list  glxtest          libmozavutil.so       libnssutil3.so    minidump-analyzer  updater.ini
dmd.py              gmp-clearkey     libmozgtk.so          libplc4.so        omni.ja            update-settings.ini
firefox             icons            libmozsandbox.so      libplds4.so       pingsender         vaapitest

[mik@labo:~/Downloads/firefox]$ MOZ_ENABLE_WAYLAND=1 ./firefox -ProfileManager -no-remote
bash: ./firefox: cannot execute: required file not found

[mik@labo:~/Downloads/firefox]$ ./firefox
bash: ./firefox: cannot execute: required file not found

Also I noticed issues with wayland on the page you link in the issue. I am on sway. And mutter is not installed.

I will try with mutter. But I will not have the time before long. Could you try to reproduce this bug ? I am pretty sure it's related to sway.

Okay, we'd need a backtrace of the crash. Please try to:

  1. try to run Firefox with Wayland logging, make it crash and attach the log.txt here:
WAYLAND_DEBUG=1 firefox > log.txt 2>&1
  1. install firefox debuginfo packages according to your distro
  2. check if there's anything in coredumpctl from previous crashes:
    https://fedoraproject.org/wiki/Debugging_guidelines_for_Mozilla_products#Using_coredumpctl_to_get_backtrace
  3. if coredumpctl is missing try to run Firefox under gdb and attach the backtrace here:
    https://fedoraproject.org/wiki/Debugging_guidelines_for_Mozilla_products#Using_local_debugging

Thanks.

Flags: needinfo?(m.viey)

(In reply to Martin Stránský [:stransky] (ni? me) from comment #8)

Okay, we'd need a backtrace of the crash. Please try to:

  1. try to run Firefox with Wayland logging, make it crash and attach the log.txt here:
WAYLAND_DEBUG=1 firefox > log.txt 2>&1
  1. install firefox debuginfo packages according to your distro
  2. check if there's anything in coredumpctl from previous crashes:
    https://fedoraproject.org/wiki/Debugging_guidelines_for_Mozilla_products#Using_coredumpctl_to_get_backtrace
  3. if coredumpctl is missing try to run Firefox under gdb and attach the backtrace here:
    https://fedoraproject.org/wiki/Debugging_guidelines_for_Mozilla_products#Using_local_debugging

Thanks.

I trying this thanks. FYI I tried with webgl disabled work around (see nix github issue) and this resolves the issue.

Flags: needinfo?(m.viey)
Attached file log.txt

This is a session with webgl enabled resulting in a crash after login in discrod

I think we could closed this issue as duplicated of https://bugzilla.mozilla.org/show_bug.cgi?id=1861365

Status: UNCONFIRMED → RESOLVED
Closed: 5 months ago
Duplicate of bug: 1861365
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: