Crash if I print this page [@ nsImageListener::OnStartDecode ]

VERIFIED DUPLICATE of bug 186228

Status

()

--
critical
VERIFIED DUPLICATE of bug 186228
16 years ago
16 years ago

People

(Reporter: Jingyu.Qiao, Assigned: rods)

Tracking

({crash})

Trunk
x86
Windows XP
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2.1) Gecko/20021130

I am using a Japanese OS (2K & XP) and an English Mozilla. When I printed the
Simplified Chinese Page
(http://www.ccidnet.com/news/industry/2001/07/18/83_51088.html), my Mozilla
crashed. I tested 4 kinds of printer, the result is the same.

Reproducible: Always

Steps to Reproduce:
1.Open http://www.ccidnet.com/news/industry/2001/07/18/83_51088.html
2.Click the [Print] button
3.Click [OK] in the Printing dialog

Actual Results:  
My Mozilla crashed!

Comment 1

16 years ago
can you post Talkback ID for this crash "mozilla/bin/components/talkback.exe" ?
Keywords: crash, stackwanted

Comment 2

16 years ago
WFM - current trunk CVS based build - WinXP-Sp1.
(Reporter)

Comment 3

16 years ago
My Mozilla cannot create a Talkback ID. And I cannot find a "talkback.exe" file
and a "mozilla/bin/components/ folder". Is such a file included in a Windows
X-86 package?

I used the "Quality Feedback Agent" reporting the error. If you can access it,
maybe you can find some information (Talkback ID) you want to know. I wrote down
the "Bug 186739" in the comment of "Quality Feedback Agent"'s report for a rapid
search.

Comment 4

16 years ago
The Netscape Feedback agent is the Talkback utility I was thinking of, as you
have submitted feedback information, you should be able to find the following
file "talkback.exe" usually located in Mozilla's subdirectory :
"mozilla\components\talkback.exe" or "mozilla\bin\components\talkback.exe"
(Reporter)

Comment 5

16 years ago
HaHa, it is there. The incident ID is TB15481405X, and the type is Program Crash.

Updated

16 years ago
Blocks: 185584
Whiteboard: TB15481405X

Updated

16 years ago
No longer blocks: 185584
0x00000000
nsImageListener::OnStartDecode
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsImageFrame.cpp, line 2335]
imgRequestProxy::OnStartDecode
[c:/builds/seamonkey/mozilla/modules/libpr0n/src/imgRequestProxy.cpp, line 311]
imgRequest::NotifyProxyListener
[c:/builds/seamonkey/mozilla/modules/libpr0n/src/imgRequest.cpp, line 179]
httpValidateChecker::OnStartRequest
[c:/builds/seamonkey/mozilla/modules/libpr0n/src/imgLoader.cpp, line 927]
nsHttpChannel::HandleAsyncNotModified
[c:/builds/seamonkey/mozilla/netwerk/protocol/http/src/nsHttpChannel.cpp, line 402]
nsHttpChannel::AsyncCall_EventHandlerFunc
[c:/builds/seamonkey/mozilla/netwerk/protocol/http/src/nsHttpChannel.cpp, line 248]
PL_HandleEvent [c:/builds/seamonkey/mozilla/xpcom/threads/plevent.c, line 645]
PL_ProcessPendingEvents [c:/builds/seamonkey/mozilla/xpcom/threads/plevent.c,
line 578]
_md_EventReceiverProc [c:/builds/seamonkey/mozilla/xpcom/threads/plevent.c, line
1336]
USER32.dll + 0x3d91 (0x77cf3d91)
USER32.dll + 0x438c (0x77cf438c)
nsAppShellService::Run
[c:/builds/seamonkey/mozilla/xpfe/appshell/src/nsAppShellService.cpp, line 472]
main1 [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1557]
main [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1905]
WinMain [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1925]
WinMainCRTStartup()
kernel32.dll + 0x214c7 (0x77e414c7) 
Keywords: stackwanted
Whiteboard: TB15481405X

Comment 7

16 years ago

*** This bug has been marked as a duplicate of 186228 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Summary: Crash if I print this page → Crash if I print this page [@ nsImageListener::OnStartDecode ]

Comment 8

16 years ago
verified.
Status: RESOLVED → VERIFIED
Crash Signature: [@ nsImageListener::OnStartDecode ]
You need to log in before you can comment on or make changes to this bug.