Last Comment Bug 186754 - "overflow" overrides z-index.
: "overflow" overrides z-index.
Status: RESOLVED FIXED
[fix]
:
Product: Core
Classification: Components
Component: Layout: View Rendering (show other bugs)
: Trunk
: x86 All
: P1 normal with 1 vote (vote)
: ---
Assigned To: Robert O'Callahan (:roc) (Exited; email my personal email if necessary)
: Hixie (not reading bugmail)
Mentors:
http://www.bearteam.org/~laurent/show...
: 188502 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-25 08:56 PST by Laurent Martelli
Modified: 2003-02-22 18:03 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Overflow:Auto vs z-index (1.22 KB, text/html)
2002-12-25 10:44 PST, Ruslan Ismailov
no flags Details
Overflow: Auto and z-index case (1.19 KB, text/html)
2002-12-26 23:41 PST, Ruslan Ismailov
no flags Details
Overflow:Auto and Scroll overrided z-index (1.20 KB, text/html)
2003-01-10 07:37 PST, Ruslan Ismailov
no flags Details
fix (20.26 KB, patch)
2003-01-24 17:51 PST, Robert O'Callahan (:roc) (Exited; email my personal email if necessary)
bzbarsky: review+
bzbarsky: superreview+
Details | Diff | Review
Updating patch to trunk (24.59 KB, patch)
2003-02-03 20:08 PST, Robert O'Callahan (:roc) (Exited; email my personal email if necessary)
no flags Details | Diff | Review

Description Laurent Martelli 2002-12-25 08:56:16 PST
User-Agent:       Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20021204 Debian/1.2.7-4
Build Identifier: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20021204 Debian/1.2.7-4

If an element A with a fixed position and z-index=1 is inside another element B
with z-index=0, A does not receive mouse events such as "onclick".

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Comment 1 Ruslan Ismailov 2002-12-25 09:18:04 PST
Of course it is, it is effect of "overflow: auto;" properity. If you change it
to hidden or remove it, all be as you wish. But auto there is mean visible, so
bigger area with z-index: 0 overflow lesser area with z-index: 1.

Comment 2 Laurent Martelli 2002-12-25 09:52:23 PST
Yet, I find it strange that an element with a bugger z-index is "behind" one
with a lower z-index. CSS2 specs says "Boxes with greater stack levels are
always formatted in front of boxes with lower stack levels". So there's a
contradiction somewhere.
Comment 3 Ruslan Ismailov 2002-12-25 10:08:43 PST
I think this bug should be named: "z-index vs overflow: visible priority"
Comment 4 Olivier Cahagne 2002-12-25 10:26:47 PST
please reopen if you disagree.

*** This bug has been marked as a duplicate of 78087 ***
Comment 5 Ruslan Ismailov 2002-12-25 10:44:08 PST
Created attachment 110122 [details]
Overflow:Auto vs z-index

Sorry, I little misguided. Where is ther root of all overflow:auto bugs? I just
like to show, that overflow:auto is not working properly. Look at this testase
to see difference between Auto, Hidden and Visible. All 3 states should be
visible, because of z-index:1
Comment 6 Vladimir Ermakov 2002-12-26 12:59:34 PST
Sounds like css to me. I dont know if this is a dupe or not, ian, can you take a
look?
Comment 7 Ruslan Ismailov 2002-12-26 15:13:22 PST
It is not CSS, I sure. It is bug inside overflow:auto. Please, reopen this bug
-- it have nothing with negative z-index bug.
Comment 8 Vladimir Ermakov 2002-12-26 16:14:38 PST
reopening per coments.
Comment 9 Vladimir Ermakov 2002-12-26 16:16:07 PST
 Moving to layout, which really does sound more appropriate. I can confirm the
bug  on Win2k build 2002-12-20-08-trunk, OS-All. This is definately a bug
because it used to work on 7.01 build, at least on mac.
Comment 10 Ruslan Ismailov 2002-12-26 23:41:06 PST
Created attachment 110192 [details]
Overflow: Auto and z-index case

This testcase show, that Overflow: Auto boxes are on top of all other boxes,
even if z-index made another order.
Comment 11 Christopher Hoess (gone) 2003-01-10 07:11:37 PST
*** Bug 188502 has been marked as a duplicate of this bug. ***
Comment 12 Boris Zbarsky [:bz] (Out June 25-July 6) 2003-01-10 07:14:31 PST
views.
Comment 13 Boris Zbarsky [:bz] (Out June 25-July 6) 2003-01-10 07:16:07 PST
resummarizing to make the problem clear
Comment 14 Ruslan Ismailov 2003-01-10 07:37:35 PST
Created attachment 111179 [details]
Overflow:Auto and Scroll overrided z-index

Small change of previous testcase, included overflow:scroll box.
Comment 15 Ruslan Ismailov 2003-01-12 11:31:58 PST
I think I found -- it is backfire from bug 39621. 
Comment 16 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2003-01-24 17:51:39 PST
Created attachment 112571 [details] [diff] [review]
fix

The problem is that scrolling frames don't get their content parent hooked up
correctly when their view is created. This patch makes nsCSSFrameConstructor
pass the content-parent frame down into BuildScrollFrame so that the scrolling
view gets its zparent set right.
Comment 17 Boris Zbarsky [:bz] (Out June 25-July 6) 2003-01-24 20:35:10 PST
Comment on attachment 112571 [details] [diff] [review]
fix

we need to fix this file to not suck....
Comment 18 Hixie (not reading bugmail) 2003-02-03 18:45:03 PST
Does this patch also fix
   http://www.hixie.ch/tests/adhoc/css/box/absolute/overflow/010.html
...?
Comment 19 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2003-02-03 19:59:10 PST
No, that testcase is not fixed.

That is a weird one...
Comment 20 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2003-02-03 20:08:37 PST
Created attachment 113469 [details] [diff] [review]
Updating patch to trunk
Comment 21 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2003-02-03 20:19:13 PST
Hixie: that testcase is fixed by my patch in bug 182107.
Comment 22 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2003-02-22 18:03:53 PST
Fix checked in.

Note You need to log in before you can comment on or make changes to this bug.