downloading gives wrong filename from content-disposition

VERIFIED DUPLICATE of bug 65827

Status

SeaMonkey
UI Design
VERIFIED DUPLICATE of bug 65827
16 years ago
14 years ago

People

(Reporter: Joe M, Assigned: Samir Gehani)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20021224
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20021224

Trying to download some files (I can't figure out which) that are named by the
Content-Disposition header gives the wrong filename. The extension of the page
(in this example, '.cgi') is appended to the download filename. I've seen other
bugs like this, but they were closed.

I've reproduced this with (marginally) trimmed headers:
HTTP/1.1 200 OK
Date: Thu, 26 Dec 2002 09:30:30 GMT
Server: Apache/1.3.26 (Win32) PHP/4.2.1
X-Powered-By: PHP/4.2.1
Content-Disposition: inline; filename=history.dat
Connection: close
Content-Type: application/octet-stream

This can be accessed (whenever my comp's up) at
http://spanommers.dyndns.org:2000/test.php

Reproducible: Always

Steps to Reproduce:
1.Go to http://bugzilla.mozilla.org/attachment.cgi?id=110143&action=view
2.Note the save dialog's filename




The headers, according to
http://www.delorie.com/web/headers.cgi?url=http%3A%2F%2Fbugzilla.mozilla.org%2Fattachment.cgi%3Fid%3D110143%26action%3Dview
:

HTTP/1.1 200 OK
Date: Thu, 26 Dec 2002 09:06:19 GMT
Server: Apache/1.3.26 (Unix) mod_throttle/3.1.2
Content-Disposition: inline; filename=history.dat
Content-Length: 3470
Connection: close
Content-Type: application/octet-stream; name="history.dat"
X-Pad: avoid browser bug

*** This bug has been marked as a duplicate of 65827 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
v.
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.